Skip site navigation (1)Skip section navigation (2)
Date:      Fri, 13 Apr 2012 23:51:59 +0200
From:      Polytropon <freebsd@edvax.de>
To:        Marco Beishuizen <mbeis@xs4all.nl>
Cc:        freebsd-questions@freebsd.org
Subject:   Re: link_elf: symbol ata_controlcmd undefined
Message-ID:  <20120413235159.885b88b4.freebsd@edvax.de>
In-Reply-To: <alpine.BSF.2.00.1204132303210.3070@localhost>
References:  <alpine.BSF.2.00.1204132303210.3070@localhost>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Fri, 13 Apr 2012 23:11:22 +0200 (CEST), Marco Beishuizen wrote:
> Hi,
> 
> I noticed some messages when booting:
> ...
> link_elf: symbol ata_controlcmd undefined
> KLD file atapicam.ko - could not finalize loading
> ...
> 
> My /boot/loader.conf includes:
> ...
> atapicam_load="YES"
> hw.ata.atapi_dma="1"
> ...
> 
> Entering kldload atapicam gives:
> kldload: can't load atapicam: No such file or directory
> 
> Has anyone an idea how to load atapicam.ko?
> 
> I'm running FreeBSD-9.0-STABLE.

In FreeBSD 9, loading atapicam should not be neccessary,
as it is now part of the GENERIC kernel and has "merged
the ATA and SCSI functionality" for disks and optical
devices. Try removing it from loader.conf and try again.
(Note possible device name changing ad -> ada unless
you're using labels.)




-- 
Polytropon
Magdeburg, Germany
Happy FreeBSD user since 4.0
Andra moi ennepe, Mousa, ...



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?20120413235159.885b88b4.freebsd>