Skip site navigation (1)Skip section navigation (2)
Date:      Wed, 18 Nov 2009 22:21:17 -0500
From:      Glen Barber <glen.j.barber@gmail.com>
To:        Rolf Nielsen <listreader@lazlarlyricon.com>, amvandemore@gmail.com
Cc:        questions@freebsd.org
Subject:   Re: Loader does not load after reinstall with previous mirrored disk attached
Message-ID:  <4ad871310911181921s14c4d622r2413e40aaed818e7@mail.gmail.com>
In-Reply-To: <4B04B50E.6070504@lazlarlyricon.com>
References:  <4ad871310911181835n7b72dde1o22c73ec86dcc6c12@mail.gmail.com> <4B04B50E.6070504@lazlarlyricon.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
Hi Rolf and Adam,

Since you both seemingly responded with the same solution, I'll
respond including the more verbose response:

On Wed, Nov 18, 2009 at 10:01 PM, Rolf Nielsen
<listreader@lazlarlyricon.com> wrote:
>
> I recently, successfully, broke a gmirror by simply issuing gmirror clear on
> all the disks, three in my case. Since gmirror stores metadata in the last
> sector of the disks (according to the gmirror man page) and everything else
> is untouched, issuing a gmirror clear reverts the disks to single disk
> usage, and since the data isn't striped, the system will be able to read the
> data and mount the filesystem(s).
>

This makes sense, and hopefully I will not have to try it for some
time, next time I need to break a mirror, I will try 'clear'-ing it
first.

Thanks,

-- 
Glen Barber



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?4ad871310911181921s14c4d622r2413e40aaed818e7>