Skip site navigation (1)Skip section navigation (2)
Date:      Mon, 27 Apr 2015 22:20:23 +0200
From:      Nikos Vassiliadis <nvass@gmx.com>
To:        freebsd-questions@freebsd.org
Subject:   Re: tunneling L2 tagged traffic over IP
Message-ID:  <553E9A07.1020900@gmx.com>
In-Reply-To: <20150427143952.GA94033@admin.sibptus.tomsk.ru>
References:  <20150425174935.GA48023@admin.sibptus.tomsk.ru> <553C1F66.4060901@gmx.com> <20150426123629.GA48916@admin.sibptus.tomsk.ru> <20150427093355.GA86151@admin.sibptus.tomsk.ru> <553E400F.2040906@gmx.com> <20150427143952.GA94033@admin.sibptus.tomsk.ru>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help


On 04/27/15 16:39, Victor Sudakov wrote:
> Nikos,
>
> I have two interfaces in a bridge:
>
> # ifconfig bridge0
> bridge0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
>          ether 02:d7:d7:0d:ff:00
>          inet 10.14.133.20 netmask 0xffffffc0 broadcast 10.14.133.63
>          nd6 options=9<PERFORMNUD,IFDISABLED>
>          id 00:00:00:00:00:00 priority 61440 hellotime 2 fwddelay 15
>          maxage 20 holdcnt 6 proto rstp maxaddr 2000 timeout 1200
>          root id 00:00:00:00:00:00 priority 61440 ifcost 0 port 0
>          member: vr0 flags=1c3<LEARNING,DISCOVER,AUTOEDGE,PTP,AUTOPTP>
>                  ifmaxaddr 0 port 6 priority 128 path cost 200000
>          member: tap0 flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>
>                  ifmaxaddr 0 port 11 priority 128 path cost 2000000
> #
>
> "tcpdump -i vr0 stp" sees incoming STP traffic while "tcpdump -i tap0 stp"
> sees none no matter if net.link.bridge.pfil_onlyip is "1" or "0".
>
> I see however some IP6, IPX (!) and CDP frames.
>

STP frames are not forwarded. As well as other special frames:

>                 /*
>                  * Check if its a reserved multicast address, any address
>                  * listed in 802.1D section 7.12.6 may not be forwarded by the
>                  * bridge.
>                  * This is currently 01-80-C2-00-00-00 to 01-80-C2-00-00-0F
>                  */

FreeBSD does that unconditionally. That could probably be a tunable:)
If you have a "simple" ethernet bridge (without STP) you should
forward STP frames. I guess a patch would be welcome!

PS:
It's better if you add my email address to your reply. I will see it
fast(er).

HTH,
Nikos



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?553E9A07.1020900>