Skip site navigation (1)Skip section navigation (2)
Date:      Wed, 17 Nov 2004 12:06:52 +0100
From:      "Daniel Eriksson" <daniel_k_eriksson@telia.com>
To:        <freebsd-current@freebsd.org>
Subject:   uma_zfree_internal crash, if_em related?
Message-ID:  <!~!UENERkVCMDkAAQACAAAAAAAAAAAAAAAAABgAAAAAAAAA0VcX9IoJqUaXPS8MjT1PdsKAAAAQAAAApseX1ZIGwEy9CYL/rlBp9gEAAAAA@telia.com>

Next in thread | Raw E-Mail | Index | Archive | Help

After upgrading my 6-CURRENT box to 2004.11.14.16.00.00 (and also
2004.11.16.19.15.00), I have encountered this crash twice in 24 hours. A
system built from sources dated 2004.11.07.07.00.00 stayed up a week
straight without a hitch.

The system is a dual AthlonMP system. The dmesg from the last boot is
attached at the bottom (ACPI disabled). The first crash came with ACPI
enabled, the second with it disabled. I do have a dump from the first crash
in case someone needs further info.


Fatal trap 12: page fault while in kernel mode
cpuid = 0; apic id = 01
fault virtual address   = 0x0
fault code              = supervisor write, page not present
instruction pointer     = 0x8:0xc06c57ac
stack pointer           = 0x10:0xe32bbbf0
frame pointer           = 0x10:0xe32bbc18
code segment            = base 0x0, limit 0xfffff, type 0x1b
                        = DPL 0, pres 1, def32 1, gran 1
processor eflags        = interrupt enabled, resume, IOPL = 0
current process         = 26 (irq16: em0 atapci1+)
[thread 100000]
Stopped at      uma_zfree_internal+0xcc:        movl    %edx,0(%eax)
db> tr
uma_zfree_internal(0,1,0,c2388800,e32bbc4c,0,1,c227a3c0) at
uma_zfree_internal+0xcc
uma_zfree_arg(c10469a0,c3de8a00,0,c239e950,e32bbc8c) at uma_zfree_arg+0x3d6
m_freem(c3de8a00,0,0,c26a5ca8,a5) at m_freem+0x49
em_clean_transmit_interrupts(c2388800,c3b2a900,6b35f445,ffc03014,c2285000)
at em_clean_transmit_interrupts+0xb7
em_intr(c2388800,0,0,0,0) at em_intr+0x376
ithread_loop(c2272780,e32bbd48,0,0,0) at ithread_loop+0xb3
fork_exit(c054e5e0,c2272780,e32bbd48) at fork_exit+0x62
fork_trampoline() at fork_trampoline+0x8
--- trap 0x1, eip = 0, esp = 0xe32bbd7c, ebp = 0 ---



Here's a few system options and the dmesg:
------------------------------------------
* SCHED_4BSD, PREEMPTION, HZ=2000, ZERO_COPY_SOCKETS, AHC_ALLOW_MEMIO,
GEOM_BDE, SMP, apic
* CFLAGS= -O2 -pipe, COPTFLAGS= -O2 -pipe, CPUTYPE?=athlon-xp
* debug.mpsafenet=1, vfs.devfs.fops=1, kern.ipc.nmbclusters=32768,
kern.ipc.nsfbufs=16384
* net.inet.tcp.sendspace=524288, net.inet.tcp.recvspace=524288,
kern.ipc.maxsockbuf=2097152, kern.ipc.somaxconn=512, net.inet.tcp.rfc3390=1,
net.inet.ip.intr_queue_maxlen=200, net.inet.tcp.sack.enable=1,
net.isr.enable=0, vfs.hirunningspace=16777216


Copyright (c) 1992-2004 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.
FreeBSD 6.0-CURRENT #0: Tue Nov 16 22:26:50 CET 2004
    daniel@xxx.xxx.xxx:/usr/obj/usr/src/sys/XXX
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: AMD Athlon(tm) MP 2600+ (2000.08-MHz 686-class CPU)
  Origin = "AuthenticAMD"  Id = 0x6a0  Stepping = 0
 
Features=0x383fbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,
CMOV,PAT,PSE36,MMX,FXSR,SSE>
  AMD Features=0xc0480000<MP,AMIE,DSP,3DNow!>
real memory  = 1073217536 (1023 MB)
avail memory = 1041547264 (993 MB)
MPTable: <TYAN     PAULANER    >
FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
 cpu0 (BSP): APIC ID:  1
 cpu1 (AP): APIC ID:  0
ioapic0: Assuming intbase of 0
ioapic0 <Version 1.1> irqs 0-23 on motherboard
npx0: [FAST]
npx0: <math processor> on motherboard
npx0: INT 16 interface
pcib0: <MPTable Host-PCI bridge> pcibus 0 on motherboard
pci0: <PCI bus> on pcib0
agp0: <AMD 762 host to AGP bridge> port 0x1490-0x1493 mem
0xea100000-0xea100fff,0xec000000-0xedffffff at device 0.0 on pci0
pcib1: <MPTable PCI-PCI bridge> at device 1.0 on pci0
pci1: <PCI bus> on pcib1
pci1: <display, VGA> at device 5.0 (no driver attached)
isab0: <PCI-ISA bridge> at device 7.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <AMD 768 UDMA100 controller> port
0xf000-0xf00f,0x376,0x170-0x177,0x3f6,0x1f0-0x1f7 at device 7.1 on pci0
ata0: channel #0 on atapci0
ata1: channel #1 on atapci0
pci0: <bridge, PCI-unknown> at device 7.3 (no driver attached)
em0: <Intel(R) PRO/1000 Network Connection, Version - 1.7.35> port
0x1400-0x143f mem 0xe8000000-0xe803ffff,0xe8080000-0xe809ffff irq 16 at
device 8.0 on pci0
em0: Ethernet address: 00:04:23:ac:20:8a
em0:  Speed:N/A  Duplex:N/A
em1: <Intel(R) PRO/1000 Network Connection, Version - 1.7.35> port
0x1440-0x147f mem 0xe8040000-0xe807ffff,0xe80a0000-0xe80bffff irq 17 at
device 8.1 on pci0
em1: Ethernet address: 00:04:23:ac:20:8b
em1:  Speed:N/A  Duplex:N/A
ahc0: <Adaptec 29160 Ultra160 SCSI adapter> port 0x1000-0x10ff mem
0xe80c0000-0xe80c0fff irq 17 at device 9.0 on pci0
ahc0: [GIANT-LOCKED]
aic7892: Ultra160 Wide Channel A, SCSI Id=7, 32/253 SCBs
pcib2: <MPTable PCI-PCI bridge> at device 16.0 on pci0
pci2: <PCI bus> on pcib2
atapci1: <HighPoint HPT374 (channel 0+1) UDMA133 controller> port
0x2000-0x20ff,0x30d0-0x30d3,0x30d8-0x30df,0x30d4-0x30d7,0x30e0-0x30e7 irq 16
at device 4.0 on pci2
ata2: channel #0 on atapci1
ata3: channel #1 on atapci1
atapci2: <HighPoint HPT374 (channel 2+3) UDMA133 controller> port
0x2400-0x24ff,0x30e8-0x30eb,0x30f0-0x30f7,0x30ec-0x30ef,0x30f8-0x30ff irq 16
at device 4.1 on pci2
ata4: channel #0 on atapci2
ata5: channel #1 on atapci2
atapci3: <Promise PDC20318 SATA150 controller> port
0x3000-0x307f,0x30c0-0x30cf,0x3080-0x30bf mem
0xea000000-0xea01ffff,0xea021000-0xea021fff irq 18 at device 6.0 on pci2
atapci3: failed: rid 0x20 is memory, requested 4
ata6: channel #0 on atapci3
ata7: channel #1 on atapci3
ata8: channel #2 on atapci3
ata9: channel #3 on atapci3
atapci4: <HighPoint HPT374 (channel 0+1) UDMA133 controller> port
0x2800-0x28ff,0x3400-0x3403,0x3408-0x340f,0x3404-0x3407,0x3410-0x3417 irq 19
at device 7.0 on pci2
ata10: channel #0 on atapci4
ata11: channel #1 on atapci4
atapci5: <HighPoint HPT374 (channel 2+3) UDMA133 controller> port
0x2c00-0x2cff,0x3418-0x341b,0x3420-0x3427,0x341c-0x341f,0x3428-0x342f irq 19
at device 7.1 on pci2
ata12: channel #0 on atapci5
ata13: channel #1 on atapci5
cpu0 on motherboard
cpu1 on motherboard
orm0: <ISA Option ROMs> at iomem 0xe0000-0xe3fff,0xc0000-0xcafff on isa0
pmtimer0 on isa0
atkbdc0: <Keyboard controller (i8042)> at port 0x64,0x60 on isa0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
fdc0: <Enhanced floppy controller> at port 0x3f0-0x3f5 irq 6 drq 2 on isa0
fdc0: [FAST]
fd0: <1440-KB 3.5" drive> on fdc0 drive 0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x100>
sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
sio0: type 16550A, console
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1: port may not be enabled
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
unknown: <PNP0303> can't assign resources (port)
unknown: <PNP0c02> can't assign resources (memory)
unknown: <PNP0501> can't assign resources (port)
unknown: <PNP0700> can't assign resources (port)
Timecounters tick every 1.000 msec
ipfw2 initialized, divert loadable, rule-based forwarding disabled, default
to accept, logging unlimited
ad0: 117800MB <IC35L120AVV207-0/V24OA66A> [239340/16/63] at ata0-master
UDMA100
ad1: 117800MB <HDS722512VLAT20/V33OA60A> [239340/16/63] at ata0-slave
UDMA100
ad2: 117800MB <IC35L120AVV207-0/V24OA66A> [239340/16/63] at ata1-master
UDMA100
ad3: 117800MB <IC35L120AVV207-0/V24OA66A> [239340/16/63] at ata1-slave
UDMA100
ad4: 238475MB <WDC WD2500JB-00FUA0/15.05R15> [484521/16/63] at ata2-master
UDMA100
ad5: 238475MB <WDC WD2500JB-00FUA0/15.05R15> [484521/16/63] at ata2-slave
UDMA100
ad6: 239372MB <Maxtor 4A250J0/RAMB1TU0> [486344/16/63] at ata3-master
UDMA133
ad7: 239372MB <Maxtor 5A250J0/RAMB1TV0> [486344/16/63] at ata3-slave UDMA133
ad8: 194481MB <Maxtor 6Y200P0/YAR41BW0> [395136/16/63] at ata4-master
UDMA133
ad9: 194481MB <Maxtor 6Y200P0/YAR41VW0> [395136/16/63] at ata4-slave UDMA133
ad10: 194481MB <Maxtor 6Y200P0/YAR41BW0> [395136/16/63] at ata5-master
UDMA133
ad11: 239372MB <Maxtor 7Y250P0/YAR41BW0> [486344/16/63] at ata5-slave
UDMA133
ad12: 239372MB <Maxtor 7Y250M0/YAR51EW0> [486344/16/63] at ata6-master
SATA150
ad14: 238475MB <WDC WD2500JD-00FYB0/02.05D02> [484521/16/63] at ata7-master
SATA150
ad16: 239372MB <Maxtor 6B250S0/BANC1980> [486344/16/63] at ata8-master
SATA150
ad20: 114473MB <ST3120022A/3.06> [232581/16/63] at ata10-master UDMA100
ad21: 114473MB <ST3120022A/3.06> [232581/16/63] at ata10-slave UDMA100
ad22: 117246MB <Maxtor 6Y120L0/YAR41BW0> [238216/16/63] at ata11-master
UDMA133
ad23: 117246MB <Maxtor 6Y120L0/YAR41BW0> [238216/16/63] at ata11-slave
UDMA133
ad24: 114473MB <WDC WD1200JB-00DUA3/75.13B75> [232581/16/63] at ata12-master
UDMA100
ad25: 117800MB <IC35L120AVV207-1/V24OA66A> [239340/16/63] at ata12-slave
UDMA100
ad26: 239372MB <Maxtor 6Y250P0/YAR41BW0> [486344/16/63] at ata13-master
UDMA133
ar0: 476950MB <ATA RAID0 array> [60802/255/63] status: READY subdisks:
 disk0 READY on ad4 at ata2-master
 disk1 READY on ad5 at ata2-slave
ar1: 478744MB <ATA RAID0 array> [61031/255/63] status: READY subdisks:
 disk0 READY on ad6 at ata3-master
 disk1 READY on ad7 at ata3-slave
ar2: 583443MB <ATA RAID0 array> [74378/255/63] status: READY subdisks:
 disk0 READY on ad8 at ata4-master
 disk1 READY on ad9 at ata4-slave
 disk2 READY on ad10 at ata5-master
ar3: 234493MB <ATA RAID0 array> [29893/255/63] status: READY subdisks:
 disk0 READY on ad22 at ata11-master
 disk1 READY on ad25 at ata12-slave
ar4: 228946MB <ATA RAID0 array> [29186/255/63] status: READY subdisks:
 disk0 READY on ad23 at ata11-slave
 disk1 READY on ad24 at ata12-master
Waiting 5 seconds for SCSI devices to settle
sa0 at ahc0 bus 0 target 5 lun 0
sa0: <Seagate STT20000N 6A51> Removable Sequential Access SCSI-2 device 
sa0: 10.000MB/s transfers (10.000MHz, offset 15)
da0 at ahc0 bus 0 target 0 lun 0
da0: <QUANTUM ATLAS 10K 9WLS UCH0> Fixed Direct Access SCSI-3 device 
da0: 40.000MB/s transfers (20.000MHz, offset 31, 16bit), Tagged Queueing
Enabled
da0: 8759MB (17938986 512 byte sectors: 255H 63S/T 1116C)
da1 at ahc0 bus 0 target 1 lun 0
da1: <QUANTUM ATLAS 10K 9WLS UCH0> Fixed Direct Access SCSI-3 device 
da1: 40.000MB/s transfers (20.000MHz, offset 31, 16bit), Tagged Queueing
Enabled
da1: 8759MB (17938986 512 byte sectors: 255H 63S/T 1116C)
da2 at ahc0 bus 0 target 10 lun 0
da2: <IBM DDYS-T36950N S93E> Fixed Direct Access SCSI-3 device 
da2: 160.000MB/s transfers (80.000MHz, offset 63, 16bit), Tagged Queueing
Enabled
da2: 35003MB (71687340 512 byte sectors: 255H 63S/T 4462C)
da3 at ahc0 bus 0 target 11 lun 0
da3: <IBM IC35L036UWD210-0 S5CQ> Fixed Direct Access SCSI-3 device 
da3: 160.000MB/s transfers (80.000MHz, offset 63, 16bit), Tagged Queueing
Enabled
da3: 35003MB (71687340 512 byte sectors: 255H 63S/T 4462C)
da4 at ahc0 bus 0 target 12 lun 0
da4: <IBM DDYS-T36950N S93E> Fixed Direct Access SCSI-3 device 
da4: 160.000MB/s transfers (80.000MHz, offset 63, 16bit), Tagged Queueing
Enabled
da4: 35003MB (71687340 512 byte sectors: 255H 63S/T 4462C)
da5 at ahc0 bus 0 target 13 lun 0
da5: <IBM DDYS-T36950N S93E> Fixed Direct Access SCSI-3 device 
da5: 160.000MB/s transfers (80.000MHz, offset 63, 16bit), Tagged Queueing
Enabled
da5: 35003MB (71687340 512 byte sectors: 255H 63S/T 4462C)
SMP: AP CPU #1 Launched!
Mounting root from ufs:/dev/da0s1a
WARNING: DEVFS uses fops




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?!~!UENERkVCMDkAAQACAAAAAAAAAAAAAAAAABgAAAAAAAAA0VcX9IoJqUaXPS8MjT1PdsKAAAAQAAAApseX1ZIGwEy9CYL/rlBp9gEAAAAA>