Skip site navigation (1)Skip section navigation (2)
Date:      Sun, 2 Jun 2002 12:49:17 -0400
From:      "C J Michaels" <cjm2@earthling.net>
To:        <rahermon@iastate.edu>
Cc:        <freebsd-questions@freebsd.org>
Subject:   RE: Telnet localhost 25
Message-ID:  <CDEJIONOMGKHCNHBALKPCENCCAAA.cjm2@earthling.net>
In-Reply-To: <000001c2097d$57cc3d40$8404a8c0@TheGetto>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
FYI loopback is supposed to be 127.0.0.0/8.  Although I doubt making it a
/24 is going to cause you any real headaches, you know know.

--Chris

> -----Original Message-----
> From: owner-freebsd-questions@FreeBSD.ORG
> [mailto:owner-freebsd-questions@FreeBSD.ORG]On Behalf Of
> rahermon@iastate.edu
> Sent: Saturday, June 01, 2002 11:02 AM
> To: freebsd-questions@FreeBSD.ORG
> Subject: RE: Telnet localhost 25
>
>
>
> After much headaches for some reason I decided to check the lo0
> interface and to my surprise :-)
> # ifconfig lo0
>
> lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
>         inet6 ::1 prefixlen 128
>         inet6 fe80::1%lo0 prefixlen 64 scopeid 0x3
>
> then # ifconfig lo0 127.0.0.1 netmask 255.255.255.0 broadcast
> 127.0.0.255
>
> Problem solved. Thanks. Only posted for the benefit of future searches
> on similar problems.
>
> -----Original Message-----
> From: owner-freebsd-questions@FreeBSD.ORG
> [mailto:owner-freebsd-questions@FreeBSD.ORG] On Behalf Of
> rahermon@iastate.edu
> Sent: Thursday, May 30, 2002 7:20 AM
> To: freebsd-questions@FreeBSD.ORG
> Subject: Telnet localhost 25
>
> I was not sure where to send the question so when in doubt try this
> list.
>
> FreeBSD FW 4.6-RC FreeBSD 4.6-RC #0: Mon May 27 23:46:22 CDT 2002
> root@FW.rhbsd.dhs.org:/usr/obj/usr/src/sys/FW  i386
>
> To make a log story short the above machine is my DNS, DHCP server, and
> Firewall running NATD.
> Using ipfw and the rules that Dan O'Connor, from Freebsd cheat sheets,
> suggests on Setting-up a Dual-Homed Host.
>
> The problem: Sendmail stopped working about 5 days ago. Let me rephrase
> that, mail delivery stopped about 5 days ago.
>
>
> 	inside interface ip: 192.168.4.1
>
> if {
> 	telnet 192.168.4.1 25
> }
> Trying 192.168.4.1...
> Connected to ns1.rhbsd.dhs.org.
> Escape character is '^]'.
> 220 ns1.rhbsd.dhs.org ESMTP Sendmail 8.12.3/8.12.3; Thu, 30 May 2002
> 07:38:24 -0500 (CDT)
>
> if {
> 	telnet localhost 25
> }
> Trying ::1...
> telnet: connect to address ::1: Connection refused
> Trying 127.0.0.1...
> telnet: connect to address 127.0.0.1: Operation timed out
> telnet: Unable to connect to remote host
>
> funny thing is that telnet localhost 25 only looks as above if I remove
> the following from my rules set:
> ${fwcmd} add 200 deny all from any to 127.0.0.0/8
>
> else {
> 	telnet localhost 25
> }
> Trying ::1...
> telnet: connect to address ::1: Connection refused
> Trying 127.0.0.1...
> telnet: connect to address 127.0.0.1: Permission denied
> telnet: Unable to connect to remote host
>
> I can also do {
> 	telnet 0 25
> }
> Trying 0.0.0.0...
> Connected to 0.
> Escape character is '^]'.
> 220 ns1.rhbsd.dhs.org ESMTP Sendmail 8.12.3/8.12.3; Thu, 30 May 2002
> 07:53:27 -0500 (CDT)
>
> 	# tail -f /var/log/maillog
> <snip>
> May 30 07:45:36 FW sm-mta[5032]: g4UCcOuX005032: ns1.rhbsd.dhs.org
> [192.168.4.1] did not issue MAIL/EXPN/VRFY/ETRN during connection to MTA
> May 30 07:53:51 FW sm-mta[5052]: g4UCrRuX005052: ns1.rhbsd.dhs.org
> [192.168.4.1] did not issue MAIL/EXPN/VRFY/ETRN during connection to MTA
>
> I checked:
> 	/etc/resolv.conf
> 	/etc/hosts
> 	/etc/hosts.allow
>
> I tried just telling sendmail to deliver mail somewhere else like
> 192.168.4.1 where I was able to telnet to port 25 but seems like I am to
> dense to do it.
> 	# cd /etc/mail/
> 	# make all
> 	modified fw.mc (which was created after make all)
> 	by adding LOCAL_RELAY and since it did not work MAIL_HUB
> 	I also explicitly allow localhost and 127.0.0.1 on
> /etc/mail/access
> 	Which make updated the access.db file.
> 	# make cf
> 	# make install
> 	# make restart
>
> Finally, it follows some of the errors on my maillog file.
> 	# tail -f /var/log/maillog
>
> <snip>
> May 30 08:12:59 FW sm-msp-queue[5075]: g4Q84JOZ000943: to=root,
> ctladdr=root (0/0), delay=4+05:08:40, xdelay=00:00:00, mailer=relay,
> pri=16500053, relay=localhost.rhbsd.dhs.org., dsn=4.0.0, stat=Deferred:
> Permission denied
> May 30 08:12:59 FW sm-msp-queue[5075]: g4Q84H1Y000899: to=root,
> ctladdr=root (0/0), delay=4+05:08:42, xdelay=00:00:00, mailer=relay,
> pri=16500056, relay=localhost.rhbsd.dhs.org., dsn=4.0.0, stat=Deferred:
> Permission denied
> May 30 08:12:59 FW sm-msp-queue[5075]: g4PDNvgF004004: to=root,
> delay=4+23:49:02, xdelay=00:00:00, mailer=relay, pri=18751468,
> relay=localhost.rhbsd.dhs.org., dsn=4.0.0, stat=Deferred: Permission
> denied
>
>
> After many days of reading and trying different things I don't know
> where else to look some advice will be greatly appreciated.
>
>
>
>
> To Unsubscribe: send mail to majordomo@FreeBSD.org
> with "unsubscribe freebsd-questions" in the body of the message
>
>
>
> To Unsubscribe: send mail to majordomo@FreeBSD.org
> with "unsubscribe freebsd-questions" in the body of the message
>


To Unsubscribe: send mail to majordomo@FreeBSD.org
with "unsubscribe freebsd-questions" in the body of the message




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?CDEJIONOMGKHCNHBALKPCENCCAAA.cjm2>