Skip site navigation (1)Skip section navigation (2)
Date:      Thu, 27 Jan 2011 11:04:08 -0500
From:      Lowell Gilbert <freebsd-questions-local@be-well.ilk.org>
To:        freebsd-questions@freebsd.org
Subject:   Re: Problem building GIMP 2.6.11 on 8.2-PRERELEASE
Message-ID:  <44hbcu5o5j.fsf@be-well.ilk.org>
In-Reply-To: <20110126184552.GA72717@itcom245.staff.itd.umich.edu> (William Bulley's message of "Wed, 26 Jan 2011 13:45:52 -0500")
References:  <20110126184552.GA72717@itcom245.staff.itd.umich.edu>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
William Bulley <web@umich.edu> writes:

> Everything up to this point builds okay.  Then this happens:
>
> Making all in common
> gmake[3]: Entering directory `/usr/ports/graphics/gimp-app/work/gimp-2.6.11/plug-ins/common'
> cc -DHAVE_CONFIG_H -I. -I../.. -I../.. -D_THREAD_SAFE -D_REENTRANT -I/usr/local/include/gtk-2.0 -I/usr/local/lib/gtk-2.0/include -I/usr/local/include/atk-1.0 -I/usr/local/include/cairo -I/usr/local/include/gdk-pixbuf-2.0 -I/usr/local/include/pango-1.0 -I/usr/local/include/gio-unix-2.0/ -I/usr/local/include -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include -I/usr/local/include/pixman-1 -I/usr/local/include/freetype2   -I/usr/local/include  -I/usr/local/include -DGIMP_DISABLE_DEPRECATED -DGDK_MULTIHEAD_SAFE -DGTK_MULTIHEAD_SAFE  -O2 -fno-strict-aliasing -pipe -Wall -Wdeclaration-after-statement -Wmissing-prototypes -Wmissing-declarations -Winit-self -Wpointer-arith -Wold-style-definition -MT file_pdf-file-pdf.o -MD -MP -MF .deps/file_pdf-file-pdf.Tpo -c -o file_pdf-file-pdf.o `test -f 'file-pdf.c' || echo './'`file-pdf.c
> file-pdf.c:30:21: error: poppler.h: No such file or directory

[...]

> And poppler.h exists here:
>
>    /usr/local/include/poppler/glib/poppler.h
>
> and here:
>
>    /usr/ports/graphics/poppler/work/poppler-0.14.5/glib/poppler.h
>
> and here:
>
>    /usr/ports/graphics/poppler-gtk/work/poppler-0.14.5/glib/poppler.h
>
> and they are all identical.

Only the first counts, and it's the one that should be used.

You may be doing something strange in the build; you don't mention how
you started the build.  Definitely make sure you do a "make clean"
before restarting it, and make sure that poppler shows up up in the list
of installed ports ("pkg_info").



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?44hbcu5o5j.fsf>