Skip site navigation (1)Skip section navigation (2)
Date:      Wed, 04 Jul 2007 12:30:04 -0400
From:      Gerard <gerard@seibercom.net>
To:        User Questions <freebsd-questions@freebsd.org>
Subject:   Re[2]: The worst error message in history belongs to... BIND9!
Message-ID:  <20070704121712.20F6.GERARD-SEIBERT@seibercom.net>
In-Reply-To: <BMEDLGAENEKCJFGODFOCCEDGCAAA.tedm@toybox.placo.com>
References:  <20070703163610.GA6012@ayn.mi.celestial.com> <BMEDLGAENEKCJFGODFOCCEDGCAAA.tedm@toybox.placo.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On July 04, 2007 at 09:53AM Ted Mittelstaedt wrote:

[snip]

> Actually perl has a lot of problems too.  One of the biggest is that
> perl script writers always seem to think like you, in that perl is
> consistent across all platforms.
> 
> The biggest problems I've seen with perl scripts are when people use
> perl extensions that are not on the system.  You then have to go find
> the extension they use and very few of the perl script writers seem
> to be smart enough to put a section at the beginning of their scripts
> that define the CPAN location of the particular extensions they are
> using.  The second biggest problem is perl script writers using
> constructs that are valid in Perl 5.6 and later but not valid in
> Perl 5.0   I don't know how many times I've wanted to strangle
> someone when trying to run a perl script under Perl 5.0 that had
> ONE single friggin statement in the entire thousand line script that
> isn't valid under 5.0 but is under 5.6  And I've also run across
> a number of Perl extensions that won't run under 5.0 as well, even
> though the authors are supposed to regression test under 5.0

I was under the impression that Perl 5.6.0 was released on 2000-Mar-22,
while Perl 5.000 was issued on or about 1994-Oct-17. For the life of
me, I cannot comprehend why anyone would be using such an antiquated
version. I have a rather limited knowledge of Perl; however, I am not
going to be bothered regression testing it under a seven year old
obsoleted version. I believe that FreeBSD-3.4 was released around
12/21/1999 or there about. Should we also be testing against that
version also?


-- 
Gerard



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?20070704121712.20F6.GERARD-SEIBERT>