Skip site navigation (1)Skip section navigation (2)
Date:      Fri, 10 Feb 2012 10:31:26 -0600
From:      Joshua Isom <jrisom@gmail.com>
To:        freebsd-questions@freebsd.org
Subject:   Re: Resetting RAID1 drive as Non-RAID
Message-ID:  <4F35465E.2020409@gmail.com>
In-Reply-To: <4F35187D.4090902@webtent.org>
References:  <4F35187D.4090902@webtent.org>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On 2/10/2012 7:15 AM, Robert Fitzpatrick wrote:
> I have a FreeBSD 9.0 server with an Intel RAID card that has two array
> mirrors of which one has failed. The remote host was not responding and
> had it reset to find in the RAID utility one of the drives had failed
> one of the  RAID 1 arrays. Perhaps I shouldn't have, but I told the
> utility to use the drive again and it added back to the array with the
> 'Rebuild' message on the array, which means to rebuild the array within
> the OS. I went into the system as single user mode and did a 'fsck -y'
> on all the /etc/fstab mounts...
>
>> backup# cat /etc/fstab
>> # Device                Mountpoint      FStype  Options
>> Dump    Pass#
>> /dev/ar0s1b             none            swap    sw              0       0
>> /dev/ar0s1a             /               ufs     rw              1       1
>> /dev/ar0s1f             /home           ufs     rw              2       2
>> /dev/ar0s1d             /usr            ufs     rw              2       2
>> /dev/ar0s1e             /var            ufs     rw              2       2
>> #/dev/ar1s1d            /data           ufs
>> rw,userquota,groupquota        2 2
>> /dev/acd0               /cdrom          cd9660  ro,noauto       0       0
>
> The drive that failed is in the ar1 array. I can mount /data in single
> user mode and see all files fine, but it continues to report INCORRECT
> BLOCK COUNT messages and UNEXPECTED SOFT UPDATE INCONSISTENCY errors as
> well as allocated frags marked free and reports CLEAN no matter how many
> times I run fsck on the drive.  I can mount the /data partition in
> normal mode, but will receive errors about 'lock order reversal' when
> doing umount on the drive or it will lock the system after several
> minutes with panic error if left mounted.
>
> Assuming my problem is that the drive needs to be replaced, now that the
> drive is in the array again, the utility no longer indicates which drive
> is bad. I believe I remember which it was, but not 100% sure. Is there a
> way to determine which physical drive is bad using FreeBSD? If able to
> reset to Non-RAID, would that allow FreeBSD to mount the DEGRADED array
> and continue to access to the data or does the drive need to be pulled
> in order to possibly satisfy FreeBSD to allow me to mount RAID-1 array
> DEGRADED? In the end, I am hoping to mount this array with the one drive
> until I can get the replacement drive installed. Thanks for any help, I
> realize some of this is related to the Intel RAID, just wanted to see if
> someone was familiar with how to recover from such a situation.
>
> _______________________________________________
> freebsd-questions@freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe@freebsd.org"

Using smartctl might be able to tell you which drive had a problem. 
It's not a guarantee though.

Try the simple method, open up the case, unplug one drive and boot.  If 
it works, you pulled the right drive.  If it doesn't, try the other 
instead.  If neither drive works right, attempt to update your backup asap.



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?4F35465E.2020409>