Skip site navigation (1)Skip section navigation (2)
Date:      Sat, 22 Aug 2020 00:02:06 +0100
From:      tech-lists <tech-lists@zyxst.net>
To:        freebsd-questions@freebsd.org
Subject:   adding disk to zfs mirror after removal of disk
Message-ID:  <20200821230206.GA56267@bastion.zyxst.net>

Next in thread | Raw E-Mail | Index | Archive | Help

--NzB8fVQJ5HfG6fxh
Content-Type: text/plain; charset=us-ascii; format=flowed
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

Hi,

I seem to have broken the zpool on a mirror setup. One of the disks showed
errors, so detached it and ran a dd rw over the entire disk to make the
hardware remap bad blocks. I then attached it to the pool and it resilvered.
Problem is now, the pool doesn't show its pooltype ie mirror-0, there's
nothing where mirror-0 was, just the two disks.

How to fix?

thanks,
--=20
J.

--NzB8fVQJ5HfG6fxh
Content-Type: application/pgp-signature; name="signature.asc"

-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEE8n3tWhxW11Ccvv9/s8o7QhFzNAUFAl9AUnwACgkQs8o7QhFz
NAUG+w/9HRqGDFftz/tyU3SqARxEpHwhv0G2IVhY/ln7eyeSaSeZk/GhqY1Hp7Wn
Jy9a4fKGIspzPsEYgIHtboJkHWw4SsqBn0csNsxGl1uL1frorqU6cluOtfOakJTi
yfLtrj6s4va6t8iE5i+P6jEMyRvDolSMI9EK0/XnxmWuNaaIpR9/eqWuhqIEhmBJ
yO2UP6KQMTOERmvER+FHcEHVuilbALQ0eocwzX8gB46/Llb3NJhzBovZjNZeQVFx
Yzc31YtkwfXKOglW0qJjQfO2Gap3jZPSPIOMaBla21u4movj7fZBsGx2eSl7LFOi
IKz9nzHb+HFJ5No8X9rPi7mmbcHh2Brds3ssZEEd+XUyrzOFp27Q4vCUZ7+DqOOY
YthbbXCcpnNJniFisnpez3fX3MlbgmHFwb+SneNSrkg0wHWzG26Tm3VTWN52qf6Z
NqLgj4S+gjIrtdq3PBEz8XUJHb/HWfJQg1VosBJCCL2Sypa5jtVTJbGtmg+XR4zD
MzwnYDJQawSPfjUeBG8VGH7asD8aQRPQ2qOVivPicc/O/vE29UeiMtHeImjHmqwO
W4C8kfDXb7TK2UIfA46RJYqdnRjfjoc4nIyNVhi+hXKuvZrzz6b0uxtF1KYEJOuv
+l1b38SEsu6V0EpS4coodurc5Thgolw5dSu84I+gQnKOOfbwdYk=
=T9rV
-----END PGP SIGNATURE-----

--NzB8fVQJ5HfG6fxh--



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?20200821230206.GA56267>