Skip site navigation (1)Skip section navigation (2)
Date:      Sun, 24 Mar 2013 21:23:45 +0700
From:      Erich Dollansky <erichsfreebsdlist@alogt.com>
To:        uki <ukaszg@gmail.com>
Cc:        questions@freebsd.org
Subject:   Re: can not use intel GPU, no /dev/dri/card0
Message-ID:  <20130324212345.300ed438@X220.ovitrap.com>
In-Reply-To: <CAN_VB4X3tBrYdZLXWdV0NV3s2JH-F=S7CRvMEVV2kr9KUykpPA@mail.gmail.com>
References:  <CAN_VB4X3tBrYdZLXWdV0NV3s2JH-F=S7CRvMEVV2kr9KUykpPA@mail.gmail.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
Hi,

On Sun, 24 Mar 2013 14:14:28 +0000
uki <ukaszg@gmail.com> wrote:

> Hi,
> 
> I'm getting the folowing error when I try to start X using intel
> drivers:
> 
> [  8669.844] (II)
> Loading /usr/local/lib/xorg/modules/drivers/intel_drv.so [  8669.844]
> (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
> [  8669.844] drmOpenDevice: node name is /dev/dri/card0 [  8669.844]
> Failed to change owner or group for file /dev/dri! 2: No such file or
> directory [  8669.844] Failed to change owner or group for
> file /dev/dri/card0! 2: No such file or directory
> [  8669.844] drmOpenDevice: open result is -1, (No such file or
> directory) [  8669.844] Failed to change owner or group for
> file /dev/dri/card0! 2: No such file or directory
> [  8669.844] drmOpenDevice: open result is -1, (No such file or
> directory) [  8669.844] drmOpenDevice: Open failed
> 
> I assume I overlooked something while configuring the system (I dual
> boot stable and release, this is on stable, release works fine).
> Please help.
> 
> my make.conf has:
> WITH_NEW_XORG="YES"
> WITH_KMS="YES"
> 
> my kernconf:
> device          agp
> device          dpms
> options         X86BIOS
> 
> device          drm
> device          i915drm
> device          radeondrm
> 
you should not need the last line. Delete it and see what happens.

Erich



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?20130324212345.300ed438>