Skip site navigation (1)Skip section navigation (2)
Date:      Thu, 17 Jan 2008 11:48:11 -0600
From:      Paul Procacci <pprocacci@datapipe.com>
To:        "Jack L. Stone" <jacks@sage-american.com>
Cc:        freebsd-questions@freebsd.org
Subject:   Re: MySQL Library upgrade issue
Message-ID:  <20080117174810.GA86225@procacci.kicks-ass.org>
In-Reply-To: <3.0.1.32.20080117110046.011eee60@sage-american.com>
References:  <3.0.1.32.20080117110046.011eee60@sage-american.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Thu, Jan 17, 2008 at 11:00:46AM -0600, Jack L. Stone wrote:
> Am running FBSD-6.2p10
> 
> Recently, I upgraded MySQL-4.1.22 to 5.0.x and while things seem to work
> okay, I keep getting this warning in phpMyAdmin:
> 
> "Your PHP MySQL library version 4.1.22 differs from your MySQL server
> version 5.0.51. This may cause unpredictable behavior."
> 
> Perhaps my manner of jumping the versions of MySQL...??
> 
> How do I get it to recognize the proper library version?
> 
> Thanks for any help.

The error stems from php5-mysql (or php4-mysql) being compiled against a
different set of mysql libs.  The easiest method for silencing the error is
to recompile the php5-mysql (or php4-mysql) port.

/usr/ports/databases/php5-mysql

Cheers.

> (^_^)
> Happy trails,
> Jack L. Stone
> 
> System Admin
> Sage-american
> _______________________________________________
> freebsd-questions@freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe@freebsd.org"

-- 
Paul Procacci
Manager, UNIX Support
DataPipe Managed Global IT Services
pprocacci@datapipe.com
1.201.792.4847 (international)
1.888.749.5821 (toll free)



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?20080117174810.GA86225>