Skip site navigation (1)Skip section navigation (2)


| raw e-mail | index | archive | help
    stress2: Don't run aesni.sh on non-x86 platforms
    
    aesni.ko only exists on amd64 and i386, so on other platforms we are
    just running geli.sh twice.
    
    In fact, this test has little value anymore because aesni is included in
    GENERIC, so it's always going to be used in preference to cryptosoft.
    
    Reviewed by:    pho
    MFC after:      1 week
    Differential Revision:  https://reviews.freebsd.org/D45366
---
 tools/test/stress2/misc/aesni.sh | 5 +++++
 1 file changed, 5 insertions(+)

diff --git a/tools/test/stress2/misc/aesni.sh b/tools/test/stress2/misc/aesni.sh
index a5160d82dd57..0fe7390d2fbd 100755
--- a/tools/test/stress2/misc/aesni.sh
+++ b/tools/test/stress2/misc/aesni.sh
@@ -29,6 +29,11 @@
 
 # Simple AESNI(4) test.
 
+if [ $(uname -m) != "amd64" -a $(uname -m) != "i386" ]; then
+    echo "This test requires an x86 system."
+    exit 0
+fi
+
 kldstat -v | grep -qw aesni  || { kldload aesni.ko; loaded=1; }
 
 ../misc/geli.sh



Want to link to this message? Use this URL: <https://mail-archive.FreeBSD.org/cgi/mid.cgi?>