Skip site navigation (1)Skip section navigation (2)
Date:      Thu, 14 Dec 2000 13:55:36 -0800 (PST)
From:      John Baldwin <jhb@FreeBSD.org>
To:        arch@FreeBSD.org
Subject:   kthread API
Message-ID:  <XFMail.001214135536.jhb@FreeBSD.org>

next in thread | raw e-mail | index | archive | help
Hey all,

I'd like to make some of the kernel API's a little more consistent as far as in
their naming.  The first one I'd like to tackle is the kthread API. 
Specifically, I'd like to stick the whole API under a kthread_* API.  This
would result in the following:

Old Name                New Name
--------                --------
kproc_start             kproc_start
shutdown_kproc          kproc_shutdown
kthread_create          kthread_create
kthread_exit            kthread_exit
resume_kproc            kthread_resume
suspend_kproc           kthread_suspend
kproc_suspend_loop      kthread_suspend_check

The description of all of these can be found in kthread(9).  I kept the kproc_
prefix for start and shutdown because those functions are wrappers used
specifically with the kernel daemons (pagedaemon, vmdaemon, etc.) whereas the
other functions may operate on any kernel thread.  I'm not opposed to sticking
those under kthread_* if that is what everyone else wants however.  After
kthread_*, I plan to probably stick the software interrupt API under a swi_*
namespace.  If I get this committed, I'll fix update the manpage as well.  The
patch can be found at http://www.FreeBSD.org/~jhb/patches/kthread.patch.

-- 

John Baldwin <jhb@FreeBSD.org> -- http://www.FreeBSD.org/~jhb/
PGP Key: http://www.baldwin.cx/~john/pgpkey.asc
"Power Users Use the Power to Serve!"  -  http://www.FreeBSD.org/


To Unsubscribe: send mail to majordomo@FreeBSD.org
with "unsubscribe freebsd-arch" in the body of the message




Want to link to this message? Use this URL: <https://mail-archive.FreeBSD.org/cgi/mid.cgi?XFMail.001214135536.jhb>