Skip site navigation (1)Skip section navigation (2)
Date:      Sun, 4 Sep 2016 03:29:36 -0400 (EDT)
From:      doug@safeport.com
To:        freebsd-questions@FreeBSD.ORG
Subject:   xdm does not work with xfce
Message-ID:  <alpine.BSF.2.00.1609040214200.40638@bucksport.safeport.com>

Next in thread | Raw E-Mail | Index | Archive | Help
I did a new install of 10.3 and the added packages for xorg and xfce. The level 
installed are: xorg-7.7_2, xfce-4.12_1.

Using startx or startxfce4 works fine. Using xdm I can do one login after a boot 
if I start xdm manually. If xdm is started frin /etc/ttys I can some time get a 
login. The problem appears to be xdm does not free display :0.

To get xdm to work I copied /usr/local/etc/X11/xinit/xinitrc to $home/.xinitrc. 
I have a .xsession file contining startxfce4. I commented out the last line in 
/usr/local/lib/X11/xdm/xdm-config.

I have output from xsession-errors and xdm.log. After the second login attempt 
.xsession-error is rewriten to contain:

       /usr/local/bin/startxfce4: X server already running on display :0

       XDM authorization key matches an existing client!xfce4-session: Cannot
       open display: . Type 'xfce4-session --help' for usage.

xdm works on a 10.1 system with xorg-7.7_1 and xfce-4.12_1.

My questions: Is this a known issue? Should this be posted on the X11 
mailing list?

_____
Douglas Denault
http://www.safeport.com
doug@safeport.com
Voice: 301-217-9220
   Fax: 301-217-9277



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?alpine.BSF.2.00.1609040214200.40638>