Skip site navigation (1)Skip section navigation (2)
Date:      Thu, 1 Feb 2007 18:37:37 +0300 (MSK)
From:      "Igor V. Ruzanov" <igorr@canmos.ru>
To:        questions@FreeBSD.org
Subject:   NeedHelp
Message-ID:  <Pine.LNX.4.64.0702011806590.7391@sta1.canmos.ru>

Next in thread | Raw E-Mail | Index | Archive | Help
Hello!
I have installed FreeBSD 6.1-RELEASE onto server machine with 
ASUS P5RD1-VM mainboard. There is network interface card integrated 
(nic) into the mainboard and this nic based on ULi-M526X chipset that is 
not determined under FreeBSD. Is there some workaround with ULi-M526X nic 
to make this nic operable? Or maybe i have to upgarde system to FreeBSD 
6.2-RELEASE?

There are several system configurations that could be helpfull for you:
1) Kernel options with respect to FastEthernet support:
=======================================================
# PCI Ethernet NICs that use the common MII bus controller code.
# NOTE: Be sure to keep the 'device miibus' line in order to use these NICs!
device          miibus          # MII bus support
device          bce             # Broadcom BCM5706/BCM5708 Gigabit Ethernet
device          bfe             # Broadcom BCM440x 10/100 Ethernet
device          bge             # Broadcom BCM570xx Gigabit Ethernet
device          dc              # DEC/Intel 21143 and various workalikes
device          fxp             # Intel EtherExpress PRO/100B (82557, 82558)
device          lge             # Level 1 LXT1001 gigabit Ethernet
device          nge             # NatSemi DP83820 gigabit Ethernet
device          nve             # nVidia nForce MCP on-board Ethernet Networking
device          pcn             # AMD Am79C97x PCI 10/100(precedence over 'lnc')
device          re              # RealTek 8139C+/8169/8169S/8110S
device          rl              # RealTek 8129/8139
device          sf              # Adaptec AIC-6915 (``Starfire'')
device          sis             # Silicon Integrated Systems SiS 900/SiS 7016
device          sk              # SysKonnect SK-984x & SK-982x gigabit Ethernet
device          ste             # Sundance ST201 (D-Link DFE-550TX)
device          ti              # Alteon Networks Tigon I/II gigabit Ethernet
device          tl              # Texas Instruments ThunderLAN
device          tx              # SMC EtherPower II (83c170 ``EPIC'')
device          vge             # VIA VT612x gigabit Ethernet
device          vr              # VIA Rhine, Rhine II
device          wb              # Winbond W89C840F
device          xl              # 3Com 3c90x (``Boomerang'', ``Cyclone'')

2) PCI channels configurations:
===============================
hostb0@pci0:0:0: class=0x060000 card=0x819a1043 chip=0x5a331002 rev=0x01 hdr=0x00
     vendor   = 'ATI Technologies Inc'
     class    = bridge
     subclass = HOST-PCI
pcib1@pci0:1:0: class=0x060400 card=0x000000b0 chip=0x5a3f1002 rev=0x00 hdr=0x01
     vendor   = 'ATI Technologies Inc'
     class    = bridge
     subclass = PCI-PCI
pcib2@pci0:25:0: class=0x060400 card=0x000000c0 chip=0x524910b9 rev=0x00 hdr=0x01
     vendor   = 'Acer Labs Incorporated (ALi)'
     device   = 'M5249 HyperTransport to PCI Bridge'
     class    = bridge
     subclass = PCI-PCI
none0@pci0:27:0: class=0x020000 card=0x816a1043 chip=0x526310b9 rev=0x50 hdr=0x00
     vendor   = 'Acer Labs Incorporated (ALi)'
     class    = network
     subclass = ethernet
isab0@pci0:30:0: class=0x060100 card=0x80561043 chip=0x157310b9 rev=0x31 hdr=0x00
     vendor   = 'Acer Labs Incorporated (ALi)'
     class    = bridge
     subclass = PCI-ISA
none1@pci0:30:1: class=0x068000 card=0x80561043 chip=0x710110b9 rev=0x00 hdr=0x00
     vendor   = 'Acer Labs Incorporated (ALi)'
     device   = 'ALI M7101 Power Management Controller'
     class    = bridge
atapci0@pci0:31:0:     class=0x01018a card=0x80561043 chip=0x522910b9 rev=0xc7 hdr=0x00
     vendor   = 'Acer Labs Incorporated (ALi)'
     device   = 'M1543 Southbridge EIDE Controller'
     class    = mass storage
     subclass = ATA
none2@pci1:5:0: class=0x030000 card=0x819a1043 chip=0x5a611002 rev=0x00 hdr=0x00
     vendor   = 'ATI Technologies Inc'
     class    = display
     subclass = VGA
skc0@pci2:19:0: class=0x020000 card=0x952111ab chip=0x432011ab rev=0x12 hdr=0x00
     vendor   = 'Marvell Semiconductor (Was: Galileo Technology Ltd)'
     device   = '88E8001/8003/8010 Gigabit Ethernet Controller with Integrated PHY (copper)'
     class    = network
     subclass = ethernet
fxp0@pci2:20:0: class=0x020000 card=0x00098086 chip=0x12298086 rev=0x05 hdr=0x00
     vendor   = 'Intel Corporation'
     device   = '82550/1/7/8/9 EtherExpress PRO/100(B) Ethernet Adapter'
     class    = network
     subclass = ethernet


PS I tried to `kldload' to loade a module that i got from my friends so 
ndis0 interface was created. But when i assigned network to ndis0, my 
system was crashed.

Thank you for your help!

+-------------------------------------------+
! CANMOS ISP Network                        !
+-------------------------------------------+
! Best regards                              !
! Igor V. Ruzanov, network operational staff!
! e-Mail: igorr@canmos.ru                   !
+-------------------------------------------+



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?Pine.LNX.4.64.0702011806590.7391>