Skip site navigation (1)Skip section navigation (2)
Date:      Thu, 26 Jul 2007 20:25:16 +0200
From:      Martin Schweizer <office@pc-service.ch>
To:        g@pcs.ms
Subject:   Re: Upgrade xorg 6.9 to 72
Message-ID:  <20070726182516.GA2928@saturn.pcs.ms>
Resent-Message-ID: <200707261830.l6QIUIca003020@saturn.pcs.ms>
In-Reply-To: <20070723212314.581ba52f@gumby.homeunix.com.>
References:  <20070722171516.GA81747@saturn.pcs.ms> <20070722221650.6e721f26@gumby.homeunix.com.> <20070723192251.GA86535@saturn.pcs.ms> <20070723212314.581ba52f@gumby.homeunix.com.>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help

--9amGYk9869ThD9tj
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

Hello RW

Am Mon, Jul 23, 2007 at 09:23:14PM +0100 RW schrieb:

> > > > I read UPDATING and did all the steps described there.=20
> > >=20
> > > No, you didn't because /usr/ports/x11/xorg-libraries/Makefile
> > > contains a little test to make sure you have read UPDATING.
> >=20
> > No, it's not correct. I followed the steps from top to down. Since I
> > have no gstreamer ports (I did not find any) I used portupgrade -a.
> > After this I get the output as I send before.
> > Yes, I checked also the .../xorg-libraries/Makefile and saw the if
> > loop. I now too that after portupgrade -a went I need further steps
> > too (symlinks etc.). Since I'm not 100% shure that this output is
> > correct I wrote this mail. So if I do something wrong please give me
> > a hint where I did something wrong. Any hints are welcome.
>=20
>=20
> You haven't mentioned setting XORG_UPGRADE.

I've checked of course the environment. I set both variables setenv BATCH=
=20
yes and setenv XORG_UPGRADE yes.

[snip]
=3D=3D=3D>  Cleaning for xorg-libraries-7.2_1
Read /usr/ports/UPDATING for the procedure to upgrade or install xorg 7.2.
*** Error code 1

Stop in /usr/ports/x11/xorg-libraries.
** Command failed [exit code 1]: /usr/bin/script -qa /tmp/portupgrade.83788=
.90=20
env UPGRADE_TOOL=3Dportupgrade UPGRADE_PORT=3Dxorg-libraries-6.9.0_1=20
UPGRADE_PORT_VER=3D6.9.0_1 make
** Fix the problem and try again.

The only one I saw is the above line but I have no idea what this mean. Do =
you=20
have any ideas?


--->  Skipping 'x11/xterm' (xterm-224) because a requisite package=20
'xorg-libraries-6.9.0_1' (x11/xorg-libraries) failed (specify -k to force)
--->  Skipping 'audio/nas' (nas-1.8) because a requisite package=20
'xorg-libraries-6.9.0_1' (x11/xorg-libraries) failed (specify -k to force)
--->  Skipping 'x11-toolkits/qt33' (qt-3.3.7_1) because a requisite package=
=20
'nas-1.8' (audio/nas) failed (specify -k to force)
--->  Skipping 'x11-toolkits/tk84' (tk-8.4.14_2,2) because a requisite pack=
age=20
'xorg-libraries-6.9.0_1' (x11/xorg-libraries) failed (specify -k to force)
--->  Skipping 'devel/dbus' (dbus-1.0.2) because a requisite package=20
'xorg-libraries-6.9.0_1' (x11/xorg-libraries) failed (specify -k to force)
--->  Skipping 'java/diablo-jdk15' (diablo-jdk-1.5.0.07.01_3) because a=20
requisite package 'xorg-libraries-6.9.0_1' (x11/xorg-libraries) failed=20
(specify -k to force)
--->  Skipping 'x11-servers/xorg-vfbserver' (xorg-vfbserver-6.9.0_2) becaus=
e a=20
requisite package 'xorg-libraries-6.9.0_1' (x11/xorg-libraries) failed=20
(specify -k to force)
--->  Skipping 'graphics/libwmf' (libwmf-0.2.8.4) because a requisite packa=
ge=20
'xorg-libraries-6.9.0_1' (x11/xorg-libraries) failed (specify -k to force)
--->  Skipping 'x11-toolkits/gtk12' (gtk-1.2.10_17) because a requisite=20
package 'xorg-libraries-6.9.0_1' (x11/xorg-libraries) failed (specify -k to=
=20
force)
--->  Skipping 'x11-fonts/xfs' (xorg-fontserver-6.9.0_1) because a requisit=
e=20
package 'xorg-libraries-6.9.0_1' (x11/xorg-libraries) failed (specify -k to=
=20
force)
--->  Skipping 'print/ghostscript-gnu' (ghostscript-gnu-7.07_15) because a=
=20
requisite package 'xorg-libraries-6.9.0_1' (x11/xorg-libraries) failed=20
(specify -k to force)
--->  Skipping 'x11-fonts/urwfonts' (urwfonts-1.0_1) because a requisite=20
package 'xorg-libraries-6.9.0_1' (x11/xorg-libraries) failed (specify -k to=
=20
force)
--->  Skipping 'graphics/dri' (dri-6.4.1,2) because a requisite package=20
'xorg-libraries-6.9.0_1' (x11/xorg-libraries) failed (specify -k to force)
--->  Skipping 'x11-servers/xorg-nestserver' (xorg-nestserver-6.9.0_1) beca=
use=20
a requisite package 'xorg-libraries-6.9.0_1' (x11/xorg-libraries) failed=20
(specify -k to force)
--->  Skipping 'devel/apache-ant' (apache-ant-1.7.0) because a requisite=20
package 'xorg-libraries-6.9.0_1' (x11/xorg-libraries) failed (specify -k to=
=20
force)
--->  Skipping 'devel/dbus-glib' (dbus-glib-0.73) because a requisite packa=
ge=20
'xorg-libraries-6.9.0_1' (x11/xorg-libraries) failed (specify -k to force)
--->  Skipping 'x11-servers/xorg-printserver' (xorg-printserver-6.9.0_2)=20
because a requisite package 'xorg-libraries-6.9.0_1' (x11/xorg-libraries)=
=20
failed (specify -k to force)
--->  Skipping 'graphics/libglut' (libglut-6.4.2) because a requisite packa=
ge=20
'xorg-libraries-6.9.0_1' (x11/xorg-libraries) failed (specify -k to force)
--->  Skipping 'devel/dbus-qt3' (dbus-qt3-0.70) because a requisite package=
=20
'nas-1.8' (audio/nas) failed (specify -k to force)
--->  Skipping 'x11-servers/xorg-server' (xorg-server-6.9.0_6) because a=20
requisite package 'xorg-libraries-6.9.0_1' (x11/xorg-libraries) failed=20
(specify -k to force)
--->  Skipping 'misc/gnomehier' (gnomehier-2.2) because a requisite package=
=20
'xorg-libraries-6.9.0_1' (x11/xorg-libraries) failed (specify -k to force)
--->  Skipping 'misc/gnome-mime-data' (gnome-mime-data-2.18.0) because a=20
requisite package 'xorg-libraries-6.9.0_1' (x11/xorg-libraries) failed=20
(specify -k to force)
--->  Skipping 'graphics/GraphicsMagick' (GraphicsMagick-1.1.7) because a=
=20
requisite package 'libwmf-0.2.8.4' (graphics/libwmf) failed (specify -k to=
=20
force)
--->  Skipping 'graphics/graphviz' (graphviz-2.12_1) because a requisite=20
package 'xorg-libraries-6.9.0_1' (x11/xorg-libraries) failed (specify -k to=
=20
force)
--->  Skipping 'graphics/cairo' (cairo-1.2.6_1) because a requisite package=
=20
'xorg-libraries-6.9.0_1' (x11/xorg-libraries) failed (specify -k to force)
--->  Skipping 'graphics/poppler' (poppler-0.5.4_2) because a requisite=20
package 'xorg-libraries-6.9.0_1' (x11/xorg-libraries) failed (specify -k to=
=20
force)
--->  Skipping 'graphics/poppler-qt' (poppler-qt-0.5.4) because a requisite=
=20
package 'poppler-0.5.4_2' (graphics/poppler) failed (specify -k to force)
--->  Skipping 'graphics/libungif' (libungif-4.1.4_2) because a requisite=
=20
package 'xorg-libraries-6.9.0_1' (x11/xorg-libraries) failed (specify -k to=
=20
force)
--->  Skipping 'graphics/imlib' (imlib-1.9.15_4) because a requisite packag=
e=20
'gtk-1.2.10_17' (x11-toolkits/gtk12) failed (specify -k to force)
--->  Skipping 'devel/t1lib' (t1lib-5.1.1,1) because a requisite package=20
'xorg-libraries-6.9.0_1' (x11/xorg-libraries) failed (specify -k to force)
--->  Skipping 'audio/arts' (arts-1.5.6,1) because a requisite package=20
'nas-1.8' (audio/nas) failed (specify -k to force)
--->  Skipping 'sysutils/policykit' (policykit-0.1.20060514_3) because a=20
requisite package 'dbus-glib-0.73' (devel/dbus-glib) failed (specify -k to=
=20
force)
--->  Skipping 'sysutils/hal' (hal-0.5.8.20070210) because a requisite pack=
age=20
'dbus-glib-0.73' (devel/dbus-glib) failed (specify -k to force)
--->  Skipping 'net/avahi' (avahi-0.6.18) because a requisite package=20
'dbus-glib-0.73' (devel/dbus-glib) failed (specify -k to force)
--->  Skipping 'x11-toolkits/pango' (pango-1.14.10) because a requisite=20
package 'xorg-libraries-6.9.0_1' (x11/xorg-libraries) failed (specify -k to=
=20
force)
--->  Skipping 'x11-toolkits/gtk20' (gtk-2.10.11) because a requisite packa=
ge=20
'xorg-libraries-6.9.0_1' (x11/xorg-libraries) failed (specify -k to force)
--->  Skipping 'devel/gconf2' (gconf2-2.16.1) because a requisite package=
=20
'gtk-2.10.11' (x11-toolkits/gtk20) failed (specify -k to force)
--->  Skipping 'devel/gnome-vfs' (gnome-vfs-2.18.1) because a requisite=20
package 'hal-0.5.8.20070210' (sysutils/hal) failed (specify -k to force)
--->  Skipping 'devel/libgsf' (libgsf-1.14.3) because a requisite package=
=20
'gtk-2.10.11' (x11-toolkits/gtk20) failed (specify -k to force)
--->  Skipping 'textproc/libwpd' (libwpd-0.8.7) because a requisite package=
=20
'gtk-2.10.11' (x11-toolkits/gtk20) failed (specify -k to force)
--->  Skipping 'textproc/wv2' (wv2-0.2.3) because a requisite package=20
'gtk-2.10.11' (x11-toolkits/gtk20) failed (specify -k to force)
--->  Skipping 'x11/xorg-apps' (xorg-clients-6.9.0_3) because a requisite=
=20
package 'xterm-224' (x11/xterm) failed (specify -k to force)
--->  Skipping 'x11-fonts/p5-type1inst' (p5-type1inst-0.6.1_2) because a=20
requisite package 'xterm-224' (x11/xterm) failed (specify -k to force)
--->  Skipping 'x11-fonts/freefonts' (freefonts-0.10_2) because a requisite=
=20
package 'xorg-libraries-6.9.0_1' (x11/xorg-libraries) failed (specify -k to=
=20
force)
--->  Skipping 'x11/xorg' (xorg-6.9.0) because a requisite package 'xterm-2=
24'=20
(x11/xterm) failed (specify -k to force)
--->  Skipping 'print/teTeX-base' (teTeX-base-3.0_10) because a requisite=
=20
package 'xorg-libraries-6.9.0_1' (x11/xorg-libraries) failed (specify -k to=
=20
force)
--->  Skipping 'x11/kdelibs3' (kdelibs-3.5.6) because a requisite package=
=20
'xterm-224' (x11/xterm) failed (specify -k to force)
--->  Skipping 'misc/kdeedu3' (kdeedu-3.5.6) because a requisite package=20
'xterm-224' (x11/xterm) failed (specify -k to force)
--->  Skipping 'sysutils/kdeadmin3' (kdeadmin-3.5.6) because a requisite=20
package 'xterm-224' (x11/xterm) failed (specify -k to force)
--->  Skipping 'net/kdenetwork3' (kdenetwork-3.5.6) because a requisite=20
package 'xterm-224' (x11/xterm) failed (specify -k to force)
--->  Skipping 'accessibility/kdeaccessibility' (kdeaccessibility-3.5.6)=20
because a requisite package 'xterm-224' (x11/xterm) failed (specify -k to=
=20
force)
--->  Skipping 'x11-wm/kompmgr' (kdebase-kompmgr-3.5.6) because a requisite=
=20
package 'xterm-224' (x11/xterm) failed (specify -k to force)
--->  Skipping 'german/kde3-i18n' (de-kde-i18n-3.5.6) because a requisite=
=20
package 'xterm-224' (x11/xterm) failed (specify -k to force)
--->  Skipping 'games/kdegames3' (kdegames-3.5.6) because a requisite packa=
ge=20
'xterm-224' (x11/xterm) failed (specify -k to force)
--->  Skipping 'multimedia/kdemultimedia3' (kdemultimedia-3.5.6) because a=
=20
requisite package 'xterm-224' (x11/xterm) failed (specify -k to force)
--->  Skipping 'editors/koffice-kde3' (koffice-1.6.2,2) because a requisite=
=20
package 'gconf2-2.16.1' (devel/gconf2) failed (specify -k to force)
--->  Skipping 'x11-clocks/kdetoys3' (kdetoys-3.5.6) because a requisite=20
package 'xterm-224' (x11/xterm) failed (specify -k to force)
--->  Skipping 'graphics/kuickshow' (kdegraphics-kuickshow-3.5.6) because a=
=20
requisite package 'xterm-224' (x11/xterm) failed (specify -k to force)
--->  Skipping 'x11/kdebase3' (kdebase-3.5.6) because a requisite package=
=20
'policykit-0.1.20060514_3' (sysutils/policykit) failed (specify -k to force)
--->  Skipping 'devel/kdesdk3' (kdesdk-3.5.6) because a requisite package=
=20
'policykit-0.1.20060514_3' (sysutils/policykit) failed (specify -k to force)
--->  Skipping 'devel/kdevelop' (kdevelop-3.4.0_1) because a requisite pack=
age=20
'policykit-0.1.20060514_3' (sysutils/policykit) failed (specify -k to force)
--->  Skipping 'www/kdewebdev' (kdewebdev-3.5.6,2) because a requisite pack=
age=20
'policykit-0.1.20060514_3' (sysutils/policykit) failed (specify -k to force)
--->  Skipping 'deskutils/kdepim3' (kdepim-3.5.6) because a requisite packa=
ge=20
'policykit-0.1.20060514_3' (sysutils/policykit) failed (specify -k to force)
--->  Skipping 'misc/kdeutils3' (kdeutils-3.5.6) because a requisite packag=
e=20
'policykit-0.1.20060514_3' (sysutils/policykit) failed (specify -k to force)
--->  Skipping 'x11-themes/kdeartwork3' (kdeartwork-3.5.6_1) because a=20
requisite package 'policykit-0.1.20060514_3' (sysutils/policykit) failed=20
(specify -k to force)
--->  Skipping 'graphics/kdegraphics3' (kdegraphics-3.5.6) because a requis=
ite=20
package 'poppler-0.5.4_2' (graphics/poppler) failed (specify -k to force)
--->  Skipping 'x11/kde3' (kde-3.5.6) because a requisite package=20
'kdewebdev-3.5.6,2' (www/kdewebdev) failed (specify -k to force)
--->  Skipping 'editors/openoffice.org-2' (de-openoffice.org-2.2.0) because=
 a=20
requisite package 'gnome-vfs-2.18.1' (devel/gnome-vfs) failed (specify -k t=
o=20
force)
** Listing the failed packages (*:skipped / !:failed)
        ! x11/xorg-libraries (xorg-libraries-6.9.0_1)   (unknown build erro=
r)
        * x11/xterm (xterm-224)
        * audio/nas (nas-1.8)
        * x11-toolkits/qt33 (qt-3.3.7_1)
        * x11-toolkits/tk84 (tk-8.4.14_2,2)
        * devel/dbus (dbus-1.0.2)
        * java/diablo-jdk15 (diablo-jdk-1.5.0.07.01_3)
        * x11-servers/xorg-vfbserver (xorg-vfbserver-6.9.0_2)
        * graphics/libwmf (libwmf-0.2.8.4)
        * x11-toolkits/gtk12 (gtk-1.2.10_17)
        * x11-fonts/xfs (xorg-fontserver-6.9.0_1)
        * print/ghostscript-gnu (ghostscript-gnu-7.07_15)
        * x11-fonts/urwfonts (urwfonts-1.0_1)
        * graphics/dri (dri-6.4.1,2)
        * x11-servers/xorg-nestserver (xorg-nestserver-6.9.0_1)
        * devel/apache-ant (apache-ant-1.7.0)
        * devel/dbus-glib (dbus-glib-0.73)
        * x11-servers/xorg-printserver (xorg-printserver-6.9.0_2)
        * graphics/libglut (libglut-6.4.2)
        * devel/dbus-qt3 (dbus-qt3-0.70)
        * x11-servers/xorg-server (xorg-server-6.9.0_6)
        * misc/gnomehier (gnomehier-2.2)
        * misc/gnome-mime-data (gnome-mime-data-2.18.0)
        * graphics/GraphicsMagick (GraphicsMagick-1.1.7)
        * graphics/graphviz (graphviz-2.12_1)
        * graphics/cairo (cairo-1.2.6_1)
        * graphics/poppler (poppler-0.5.4_2)
        * graphics/poppler-qt (poppler-qt-0.5.4)
        * graphics/libungif (libungif-4.1.4_2)
        * graphics/imlib (imlib-1.9.15_4)
        * devel/t1lib (t1lib-5.1.1,1)
        * audio/arts (arts-1.5.6,1)
        * sysutils/policykit (policykit-0.1.20060514_3)
        * sysutils/hal (hal-0.5.8.20070210)
        * net/avahi (avahi-0.6.18)
        * x11-toolkits/pango (pango-1.14.10)
        * x11-toolkits/gtk20 (gtk-2.10.11)
        * devel/gconf2 (gconf2-2.16.1)
        * devel/gnome-vfs (gnome-vfs-2.18.1)
        * devel/libgsf (libgsf-1.14.3)
        * textproc/libwpd (libwpd-0.8.7)
        * textproc/wv2 (wv2-0.2.3)
        * x11/xorg-apps (xorg-clients-6.9.0_3)
        * x11-fonts/p5-type1inst (p5-type1inst-0.6.1_2)
        * x11-fonts/freefonts (freefonts-0.10_2)
        * x11/xorg (xorg-6.9.0)
        * print/teTeX-base (teTeX-base-3.0_10)
        * x11/kdelibs3 (kdelibs-3.5.6)
        * misc/kdeedu3 (kdeedu-3.5.6)
        * sysutils/kdeadmin3 (kdeadmin-3.5.6)
        * net/kdenetwork3 (kdenetwork-3.5.6)
        * accessibility/kdeaccessibility (kdeaccessibility-3.5.6)
        * x11-wm/kompmgr (kdebase-kompmgr-3.5.6)
        * german/kde3-i18n (de-kde-i18n-3.5.6)
        * games/kdegames3 (kdegames-3.5.6)
        * multimedia/kdemultimedia3 (kdemultimedia-3.5.6)
        * editors/koffice-kde3 (koffice-1.6.2,2)
        * x11-clocks/kdetoys3 (kdetoys-3.5.6)
        * graphics/kuickshow (kdegraphics-kuickshow-3.5.6)
        * x11/kdebase3 (kdebase-3.5.6)
        * devel/kdesdk3 (kdesdk-3.5.6)
        * devel/kdevelop (kdevelop-3.4.0_1)
        * www/kdewebdev (kdewebdev-3.5.6,2)
        * deskutils/kdepim3 (kdepim-3.5.6)
        * misc/kdeutils3 (kdeutils-3.5.6)
        * x11-themes/kdeartwork3 (kdeartwork-3.5.6_1)
        * graphics/kdegraphics3 (kdegraphics-3.5.6)
        * x11/kde3 (kde-3.5.6)
        * editors/openoffice.org-2 (de-openoffice.org-2.2.0)
--->  Packages processed: 0 done, 244 ignored, 68 skipped and 1 failed


--=20

Regards

Martin Schweizer
<info@pc-service.ch>

PC-Service M. Schweizer GmbH; Bannholzstrasse 6; CH-8608 Bubikon
Tel. +41 55 243 30 00; Fax: +41 55 243 33 22; http://www.pc-service.ch;
public key : http://www.pc-service.ch/pgp/public_key.asc;=20
fingerprint: EC21 CA4D 5C78 BC2D 73B7  10F9 C1AE 1691 D30F D239;


--9amGYk9869ThD9tj
Content-Type: application/pgp-signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (FreeBSD)

iD8DBQFGqOcMwa4WkdMP0jkRAnqeAKCqepD29dQZSwP6L1b3tYZJwGXdnACfbyGL
JlVM75N5vei98zy4ZzaRq2E=
=+9GX
-----END PGP SIGNATURE-----

--9amGYk9869ThD9tj--



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?20070726182516.GA2928>