Skip site navigation (1)Skip section navigation (2)
Date:      Mon, 28 Feb 2011 05:00:23 +0000
From:      Gautham Ganapathy <gautham@lisphacker.org>
To:        FreeBSD Questions <freebsd-questions@freebsd.org>
Cc:        Daniel Staal <DStaal@usa.net>, Slawomir Wojtczak <vermaden@gmx.com>
Subject:   Re: ROOT on ZFS with MBR partitions
Message-ID:  <AANLkTikGk8=YtckWjafW_pTxc7wg0tzCbu+aF+Xs3C0V@mail.gmail.com>
In-Reply-To: <A2FE1DA44E915CCCCD4FFE64@mac-pro.magehandbook.com>
References:  <20110227002604.92530@gmx.com> <A2FE1DA44E915CCCCD4FFE64@mac-pro.magehandbook.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Sun, Feb 27, 2011 at 12:45 AM, Daniel Staal <DStaal@usa.net> wrote:
> --As of February 27, 2011 12:26:04 AM +0000, Slawomir Wojtczak is alleged=
 to
> have said:
>
>> ... but none of them seems to work, after installation it hangs at boot
>> like that: http://ompldr.org/vN2tscQ
>
> --As for the rest, it is mine.
>
> Hmm. =A0Interesting. =A0I'm having the same result when trying the 'root =
on ZFS,
> boot from UFS' guide here:
> <http://wiki.freebsd.org/RootOnZFS/UFSBoot>;
>
> Anything interesting happening during your install? =A0I have an error la=
te in
> the process (During 'Step 3.1') with this command:
> Fixit# mv boot bootdir/
>
> It gives me an error saying that /bin/cp can't found/executed. =A0(I've b=
een
> trying to work around using `bin/cp -pRP boot bootdir/`. =A0Note the lack=
 of
> the leading slash.)
>
> I had tried several of the other installs from
> <http://wiki.freebsd.org/RootOnZFS>; successfully, but I don't think I'd
> tried the MBR install.
>
> Daniel T. Staal
>


I had the same problem. Today, I tried using the PCBSD dvd to install
FreeBSD on ZFS (with /boot on UFS). It kept giving errors just before
completion. However, some comments I found while googling about that
problem mentioned that the installation seemed to have completed,
which seems to be the case. Both FreeBSD and FreeDOS are now installed
on the same drive (in a VM, I'll try this on real h/w next). Still not
sure what caused the error during installation though.

Regards
Gautham Ganapathy



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?AANLkTikGk8=YtckWjafW_pTxc7wg0tzCbu+aF+Xs3C0V>