Skip site navigation (1)Skip section navigation (2)
Date:      Thu, 5 Feb 2009 21:07:10 -0800 (PST)
From:      cguan <guancalvin@yahoo.ca>
To:        freebsd-questions@freebsd.org
Subject:   Re: problem mounting dvd ISO
Message-ID:  <21866650.post@talk.nabble.com>
In-Reply-To: <gmgelr$ovp$1@ger.gmane.org>
References:  <21864688.post@talk.nabble.com> <gmgelr$ovp$1@ger.gmane.org>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help

yes, I did.

# kldstat -v | grep udf
 4    2 0xc44bd000 7000     udf.ko
		419 udf
 5    1 0xc4498000 2000     udf_iconv.ko
		423 udf_iconv
# mount -t udf /dev/md0 ../iso_mount/w2k8-amd64
mount_udf: /dev/md0: Invalid argument
# 

Is it possible the udf version is too new that the freebsd doesn't support
it? I can mount it with my ubuntu 8.10.

thanks,
Calvin


Michael Powell-6 wrote:
> 
> cguan wrote:
> 
>> 
>> Hi,
>> 
>> I'm trying to mount a w2k8 dvd iso image on freebsd 7 using mdconfig and
>> mount -t cd9660. the commands appeared to be working fine but when I look
>> at the mount point I only see a readme.txt file reads:
>> 
>> "This disc contains a "UDF" file system and requires an operating system
>> that supports the ISO-13346 "UDF" file system specification."
>> 
>> code:
>> #mdconfig -a -t vnode /path/to/w2k8.iso -u 0
>> #mount -t cd9660 /dev/md0 /mnt
>> #ls /mnt
>> readme.txt
>> 
>> 
>> if I use mount_udf, it said "Invalid argument"
>> code
>> #mount -t udf  /dev/md0 /mnt
>> mount_udf: /dev/md0: Invalid argument
>> 
>> However, mounting a CD iso image using the same way is fine.
>> 
>> How do I solve this problem? I have been googling for a couple of hours
>> but can fine an answer.
>> 
>> thanks,
>> Calvin
> 
> Have you tried loading the udf module, e.g., kldload udf.ko and maybe the 
> udf_iconv.ko prior to trying the mount command?
> 
> -Mike
> 
> 
> 
> _______________________________________________
> freebsd-questions@freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to
> "freebsd-questions-unsubscribe@freebsd.org"
> 
> 

-- 
View this message in context: http://www.nabble.com/problem-mounting-dvd-ISO-tp21864688p21866650.html
Sent from the freebsd-questions mailing list archive at Nabble.com.




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?21866650.post>