Skip site navigation (1)Skip section navigation (2)
Date:      Tue, 03 Sep 2013 15:14:48 -0400
From:      Kostas Oikonomou <k.oikonomou@att.net>
To:        freebsd-questions@freebsd.org
Subject:   /compat/linux/usr/bin/ldd always reports "not a dynamic executable"
Message-ID:  <52263528.2060804@att.net>

Next in thread | Raw E-Mail | Index | Archive | Help
I am on FreeBSD 9.1, and I'm trying to use /compat/linux/usr/bin/ldd to 
tell me what libraries are needed by libpython2.7.so, a library obtained 
from a linux system.  But all I get is "not a dynamic executable".

In fact, the same thing happens if I run this ldd on a library in 
/compat/linux/lib:

[ko@wiley /compat/linux/lib]$ /compat/linux/usr/bin/ldd -v libc-2.9.so
     not a dynamic executable
[ko@wiley /compat/linux/lib]$

What is going on?    Thanks for any help.

                             Kostas



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?52263528.2060804>