Skip site navigation (1)Skip section navigation (2)
Date:      Thu, 17 May 2007 11:07:20 -0700
From:      "Ted Mittelstaedt" <tedm@toybox.placo.com>
To:        "Ian Lord" <mailing-lists@msdi.ca>, "'James Price'" <james@digitalciti.com>, <freebsd-questions@freebsd.org>
Subject:   RE: SMP issues with i386/6.2 RELEASE and Compaq DL360 g1
Message-ID:  <BMEDLGAENEKCJFGODFOCGEBBCAAA.tedm@toybox.placo.com>
In-Reply-To: <024201c7978b$218ff7c0$6400a8c0@msdi.local>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help

Yes, here is the magic needed for this:

1) make sure you have select UNIX->LINUX 2.x as the OS type in
the BIOS  (use the HP smartcd to access this)

2) Do not strip out "unused CPU's" like I486_CPU, I586_CPU
from your kernel config file.

3) Make sure to either build a GENERIC or SMP kernel with
ALL of the devices that are in GENERIC.  Do NOT strip out any
"unused" devices.  I realize this makes the kernel bigger - but
what appears to be going on, is that the command to "wake up" the
second CPU is being sent too soon after the initial probes for the
acpi controller have taken place.  At least, that is my theory.
Another theory I have is that one of the device probes for an
unused device is tickling some piece of hardware on the motherboard
that if not otherwise tickled, the second CPU won't wake up.

I haven't done further effort to isolate this, but I've seen
the problem on the DL320 as well.  If you have the time to play with
multiple kernel configurations I'm sure you can stumble across what
the issue is.

Ted


> -----Original Message-----
> From: owner-freebsd-questions@freebsd.org
> [mailto:owner-freebsd-questions@freebsd.org]On Behalf Of Ian Lord
> Sent: Wednesday, May 16, 2007 12:24 AM
> To: 'James Price'; freebsd-questions@freebsd.org
> Subject: RE: SMP issues with i386/6.2 RELEASE and Compaq DL360 g1
>
>
>
> -----Original Message-----
> From: owner-freebsd-questions@freebsd.org
> [mailto:owner-freebsd-questions@freebsd.org] On Behalf Of James Price
> Sent: 16 mai 2007 02:51
> To: freebsd-questions@freebsd.org
> Subject: SMP issues with i386/6.2 RELEASE and Compaq DL360 g1
>
> Has anyone else seen issues while trying to boot an SMP kernel on a
> Compaq DL360 G1 with the latest P21 bios (11/2002).
>
> I can't seem to get it to recognize both processors...
>
> Thanks,
> James
>
>
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~
> I installed a 6.2 release (default install)
>
> On two dl360 G1 Today without any problem... Both processors were detected
> fine.
>
> I have a dual P3 550 and a dual P3 866
>
> It went fine without any tweaking or special kernel config
>
> _______________________________________________
> freebsd-questions@freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to
> "freebsd-questions-unsubscribe@freebsd.org"
>




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?BMEDLGAENEKCJFGODFOCGEBBCAAA.tedm>