Skip site navigation (1)Skip section navigation (2)
Date:      Fri, 9 Jan 2009 13:12:19 +0100
From:      "Alain G. Fabry" <alainfabry@belgacom.net>
To:        PstreeM China <pstreem@gmail.com>
Cc:        freebsd-questions@freebsd.org
Subject:   Re: 3945ABG wireless problems
Message-ID:  <20090109121115.GA41534@desmo.3rdrock.kicks-ass.net>
In-Reply-To: <2c66535d0901090355l64d8d1a7q3e18ef870eb813bb@mail.gmail.com>
References:  <20090109075548.GA8216@desmo.3rdrock.kicks-ass.net> <2c66535d0901090355l64d8d1a7q3e18ef870eb813bb@mail.gmail.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help

Actually, I've just sofar tried to perform a 'ifconfig wpi0 list scan' to verify which AP are available....after I have put the interface up of course. But it just gets stuck on this scan....doesn't do anything.

info from /var/log/messages

Jan  9 13:05:31 desmo sudo:   username : TTY=ttyp2 ; PWD=/data/username ; USER=root ; COMMAND=/sbin/ifconfig wpi0 scan list
Jan  9 13:05:32 desmo kernel: HERER



On Fri, Jan 09, 2009 at 07:55:11PM +0800, PstreeM China wrote:
> what tha AP you connect ??
> maybe , the wlan can not connect a AP, the hardware will turn off ...
> check your file  /etc/wpa_supp**.conf
> 
> On Fri, Jan 9, 2009 at 3:55 PM, Alain G. Fabry <alainfabry@belgacom.net>wrote:
> 
> >
> > Hi,
> >
> > I'm having problems with my 3945ABG Wireless card.
> >
> > I keep on getting "wpi0: Radio Transmitter is switched off"
> >
> > pushing 802.11 button on laptop -> Turning OFF
> > -------------------------------
> > Jan  9 07:59:08 desmo kernel: ugen0: at uhub0 port 1 (addr 2) disconnected
> > Jan  9 07:59:08 desmo kernel: ugen0: detached
> >
> > pushing 802.11 button again -> Turning ON
> > -----------------------------------------
> > Jan  9 07:59:13 desmo root: Unknown USB device: vendor 0x03f0 product
> > 0x171d bus uhub0
> > Jan  9 07:59:13 desmo kernel: ugen0: <Broadcom Corp HP Integrated Module,
> > class 224/1, rev 2.00/1.00, addr 2> on uhub0
> >
> > ifconfig wpi0 up
> > ----------------
> > Jan  9 07:58:51 desmo kernel: NEWSTATE:INIT
> > Jan  9 07:58:51 desmo kernel: Resetting the card - clearing any uploaded
> > firmware
> > Jan  9 07:58:51 desmo kernel: Loading microcode  size 0x384
> > Jan  9 07:58:51 desmo kernel: firmware status=0xffff0000, val=0x40400000,
> > result=0x40400000
> > Jan  9 07:58:51 desmo kernel: Status Match! - ntries = 0
> > Jan  9 07:58:51 desmo kernel: microcode alive notification version 10e02
> > alive 1
> > Jan  9 07:58:51 desmo kernel: microcode alive notification version 10e02
> > alive 1
> > Jan  9 07:58:51 desmo kernel: wpi0: Radio Transmitter is switched off
> > Jan  9 07:58:51 desmo kernel: state changed to 1
> > Jan  9 07:58:51 desmo kernel: wpi0: Radio transmitter is switched off
> >
> > I notice that I didn't have the license at
> > /usr/share/doc/legal/intel_wpi/LICENSE, so I grabbed it from
> > http://people.freebsd.org/~benjsc/downloads/wpi/20071102-freebsd-wpi.tar.gz<http://people.freebsd.org/%7Ebenjsc/downloads/wpi/20071102-freebsd-wpi.tar.gz>;
> >
> > /boot/loader.conf includes the following
> > ----------------------------------------
> > if_wpi_load="YES"
> > wlan_load="YES"
> > wlan_amrr_load="YES"
> > firmware_load="YES"
> > wpifw_load="YES"
> > legal.intel_wpi.license_ack=1
> >
> > What am I doing wrong here....??
> >
> > Many thanks,
> >
> > Alain
> > _______________________________________________
> > freebsd-questions@freebsd.org mailing list
> > http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> > To unsubscribe, send any mail to "
> > freebsd-questions-unsubscribe@freebsd.org"
> >
> _______________________________________________
> freebsd-questions@freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe@freebsd.org"



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?20090109121115.GA41534>