Skip site navigation (1)Skip section navigation (2)
Date:      Tue, 15 May 2012 21:34:44 -0600
From:      PseudoCylon <moonlightakkiy@yahoo.ca>
To:        "Christopher J. Ruwe" <cjr@cruwe.de>, freebsd-questions@freebsd.org
Subject:   Re: dlink dwl-122g e1 on 9-stable, working only partially? (or not at all?)
Message-ID:  <CAFZ_MYKnc5sDSK0Ms0FwENZmWpM11ONLCBRL7GWJzhOmqiBMFQ@mail.gmail.com>

Next in thread | Raw E-Mail | Index | Archive | Help
-----------------------------
>
> Message: 8
> Date: Mon, 14 May 2012 19:14:42 +0200
> From: "Christopher J. Ruwe" <cjr@cruwe.de>
> Subject: Re: dlink dwl-122g e1 on 9-stable, working only partially?
> =A0 =A0 =A0 =A0(or not at all?)
> To: freebsd-questions@freebsd.org
> Message-ID: <20120514191442.505a0a08@dijkstra.cruwe.de>
> Content-Type: text/plain; charset=3DUTF-8
>
> On Sun, 13 May 2012 23:09:34 -0600
> PseudoCylon <moonlightakkiy@yahoo.ca> wrote:
>
>> > ------------------------------
>> >
>> > Message: 11
>> > Date: Sun, 13 May 2012 01:21:30 +0200
>> > From: "Christopher J. Ruwe" <cjr@cruwe.de>
>> > Subject: Re: dlink dwl-122g e1 on 9-stable, working only partially?
>> > =A0 =A0 =A0 =A0(or not at all?)
>> > To: freebsd-questions@freebsd.org
>> > Message-ID: <20120513012130.64d78c1f@dijkstra.cruwe.de>
>> > Content-Type: text/plain; charset=3DUS-ASCII
>> >
>> > On Sat, 12 May 2012 14:49:18 +0200
>> > "Christopher J. Ruwe" <cjr@cruwe.de> wrote:
>> >
>> >> Currently I am fighting with (against?) a dlink dwl-g122 usb wlan
>> >> dongle. The casing is claiming the thing to be of H/W-version E1,
>> >> F/W-version 5.00, which I interpret as hardware and firmware.
>> >>
>> >> I am running 9-stable (FreeBSD ritchie.cruwe.de 9.0-STABLE FreeBSD
>> >> 9.0-STABLE #8 r235064: Fri May 11 21:32:52 CEST 2012
>> >> cjr@ritchie.cruwe.de:/usr/obj/usr/src/sys/RITCHIE =A0amd64) and
>> >> admittedly, dwl-g122 is not included in the hw-compatibility list
>> >> for 9.0.
>> >>
>> >> I am also aware that others have been unsuccessful, though some
>> >> time back, to get dlw-g122 e running
>> >> (http://forums.freebsd.org/showthread.php?t=3D27123).
>> >>
>> >> However, I am somewhat successful in getting the dongle recognized
>> >> by if_run.ko, though not to work as I would like to:
>> >>
>> >> dmesg gives then
>> >>
>> >> [...]
>> >> ugen0.3: <Ralink> at usbus0
>> >> run0: <Ralink 11g Adapter, class 0/0, rev 2.00/1.01, addr 3> on
>> >> usbus0 run0: MAC/BBP RT3070 (rev 0x0201), RF RT2020 (MIMO 1T1R),
>> >> address b8:a3:86:97:c1:ec ieee80211_load_module: load the
>> >> wlan_amrr module by hand for now. wlan0: Ethernet address:
>> >> b8:a3:86:97:c1:ec run0: firmware RT2870 ver. 0.236 loaded
>> >> ieee80211_load_module: load the wlan_amrr module by hand for now.
>> >> wlan0: Ethernet address: b8:a3:86:97:c1:ec
>> >> I have no explanation for the multiple occurrences, I have been
>> >> trying for some time now, though.
>> >>
>>
>> Was wlan_amrr compiled into kernel?
>
> Nope, using the module. BTW, loading the if_run module gives
>
> ieee80211_load_module: load the wlan_amrr module by hand for now.
>
> Did exactly that, i.e., loaded the wlam_amrr by hand. Do you think I
> might fare better by using in-kernel drivers instead of modules?
>
>
>> >>
>> >> sudo ifconfig wlan0 create wlandev run0 wlanmode hostap
>> >> sudo ifconfig wlan0 inet 192.168.3.1 netmask 255.255.255.0 ssid
>> >> bsdap channel -
>> >>
>>
>> If you want to use WPA, you need to run
>> # /etc/rc.d/hostapd onestart
>
> Amongst other things, I also did that.
>
>>
>> > OK, update on the situation: I can get wlan to work in AP-mode, I
>> > must not enable WPA, though. Having enabled hostapd for one time
>> > kills my wlan and requires a complete reboot.
>> >
>>
>> Did it panic? Can you post back trace?
>
>
> No, it did not panic. After trying to enable wpa, the systems becomes
> very sluggish on the network side and recovers upon pulling the dongle.
> I interpret that as some kind of crashing the driver.
>
> I would be happy to provide a back trace, I do not know how,
> though. Where do I need to look to learn that?
>
> Thanks and cheers, Christopher
>
>

I saw you have submitted PR. I have replied to it. Please check that out.
http://www.freebsd.org/cgi/query-pr.cgi?pr=3D167847


AK



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?CAFZ_MYKnc5sDSK0Ms0FwENZmWpM11ONLCBRL7GWJzhOmqiBMFQ>