Skip site navigation (1)Skip section navigation (2)
Date:      Mon, 20 May 2013 19:27:40 -0400
From:      Andre Goree <andre@drenet.net>
To:        freebsd-questions@freebsd.org
Subject:   Re: route problem
Message-ID:  <08a8caddd8d51e9067ad3cbe0c152a90@drenet.net>
In-Reply-To: <519A8F13.8000002@fuckaround.org>
References:  <519A8074.7070107@fuckaround.org> <d912f05d46dc64a4da29b9bc622b96d8@drenet.net> <519A8546.4090109@fuckaround.org> <4a61bfe6346c98bdc46bf45798d55d6e@drenet.net> <519A8F13.8000002@fuckaround.org>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On 2013-05-20 5:01 pm, Pol Hallen wrote:
> If you don't mind could you post the output of ifconfig from both 
> boxes?
> 
> server1:
> 
> re0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 
> 1500
> 	options=8209b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,WOL_MAGIC,LINKSTATE>
> 	ether 70:71:bc:94:c3:6d
> 	inet 192.168.1.250 netmask 0xffffff00 broadcast 192.168.1.255
> 	inet6 fe80::7271:bcff:fe94:c36d%re0 prefixlen 64 scopeid 0x1
> 	nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
> 	media: Ethernet autoselect (100baseTX <full-duplex>)
> 	status: active
> xl0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 
> 1500
> 	options=80008<VLAN_MTU,LINKSTATE>
> 	ether 00:60:08:6d:59:50
> 	inet 192.168.2.250 netmask 0xffffff00 broadcast 192.168.2.255
> 	inet6 fe80::260:8ff:fe6d:5950%xl0 prefixlen 64 scopeid 0x7
> 	nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
> 	media: Ethernet autoselect (100baseTX <full-duplex>)
> 	status: active
> lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
> 	options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>
> 	inet6 ::1 prefixlen 128
> 	inet6 fe80::1%lo0 prefixlen 64 scopeid 0x8
> 	inet 127.0.0.1 netmask 0xff000000
> 	nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
> 
> server2
> 
> fxp0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 
> 1500
> 	options=2009<RXCSUM,VLAN_MTU,WOL_MAGIC>
> 	ether 00:0f:fe:b3:db:8c
> 	inet6 fe80::20f:feff:feb3:db8c%fxp0 prefixlen 64 scopeid 0x6
> 	inet 192.168.2.52 netmask 0xffffff00 broadcast 192.168.2.255
> 	nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
> 	media: Ethernet autoselect (100baseTX <full-duplex>)
> 	status: active
> plip0: flags=8810<POINTOPOINT,SIMPLEX,MULTICAST> metric 0 mtu 1500
> 	nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
> lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
> 	options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>
> 	inet6 ::1 prefixlen 128
> 	inet6 fe80::1%lo0 prefixlen 64 scopeid 0x8
> 	inet 127.0.0.1 netmask 0xff000000
> 	nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
> 


On 'server1', what is the output of 'sysctl net.inet.ip.forwarding'?  
Perhaps you did not reboot after you set 'gateway_enable="YES"'?


This is from my box with forwarding enabled:
root@daemon ~ # sysctl net.inet.ip.forwarding
net.inet.ip.forwarding: 1
root@daemon ~ #


-- 
Andre Goree
-=-=-=-=-=-
Email     - andre@drenet.net
Website   - http://blog.drenet.net
PGP key   - http://www.drenet.net/0x83ADAAAB.asc
-=-=-=-=-=-



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?08a8caddd8d51e9067ad3cbe0c152a90>