Skip site navigation (1)Skip section navigation (2)
Date:      Tue, 7 Mar 2017 23:13:05 -0500 (EST)
From:      Xihong Yin <xyin@gmx.com>
To:        freebsd-questions@freebsd.org
Subject:   Xorg failed to start as normal user 
Message-ID:  <alpine.BSF.2.20.1703072304290.1506@ebhgre1.zlubzr.jrfgryy.pbz>

Next in thread | Raw E-Mail | Index | Archive | Help
Hi,

I recently upgraded from 10.3 to 11. All ports are upgraded as well. I have a strange problem, Xorg failed to start when I login as a normal user. If I login as root, Xorg can starts without a problem.

I already added the normal user to the wheel group.

Below is the error message of the failed case. Please help.


[  9822.110] (EE)
[  9822.110] (EE) Backtrace:
[  9822.117] (EE) 0: /usr/local/bin/X (OsInit+0x3fb) [0x82024d6]
[  9822.124] (EE) 1: /lib/libthr.so.3 (_pthread_sigmask+0x6a4) [0x286fceb4]
[  9822.132] (EE) 2: /lib/libthr.so.3 (_pthread_getspecific+0x110b) [0x286fcc5b]
[  9822.139] (EE) 3: ? (?+0x110b) [0xbfc0010f]
[  9822.147] (EE) 4: /usr/local/llvm39/lib/libLLVM-3.9.so (LLVMParseCommandLineO
ptions+0xa6c) [0x2a0388b8]
[  9822.155] (EE) 5: /usr/local/llvm39/lib/libLLVM-3.9.so (LLVMParseCommandLineO
ptions+0xbec) [0x2a038bb8]
[  9822.162] (EE) 6: /usr/local/llvm39/lib/libLLVM-3.9.so (_ZN4llvm2cl6Option11a
ddArgumentEv+0x8c) [0x2a02b388]
[  9822.170] (EE) 7: /usr/local/llvm37/lib/libLLVMSupport.so.3.7 (_ZNSt3__127__i
nsertion_sort_incompleteIRNS_6__lessINS_4pairIN4llvm10TimeRecordENS_12basic_stri
ngIcNS_11char_traitsIcEENS_9allocatorIcEEEEEESB_EEPSB_EEbT0_SF_T_+0x7de) [0x2e38
d15c]
[  9822.177] (EE) 8: /usr/local/llvm37/lib/libLLVMSupport.so.3.7 (_ZN4llvm3sys8W
atchdogD2Ev+0x1b2) [0x2e3cb154]
[  9822.185] (EE) 9: /usr/local/llvm37/lib/libLLVMSupport.so.3.7 (_init+0xd) [0x
2e31817a]
[  9822.192] (EE) 10: ? (_rtld_is_dlopened+0x1392) [0x28241274]
[  9822.200] (EE) 11: ? (dlopen+0x1b5) [0x2823ce5a]
[  9822.207] (EE) 12: ? (dlopen+0x24) [0x2823cb38]
[  9822.214] (EE) 13: /usr/local/lib/libGL.so.1 (_init+0x230d0) [0x28876fe4]
[  9822.222] (EE) 14: /usr/local/lib/xorg/modules/extensions/libglx.so (GlxSetVi
sualConfigs+0x6ef8) [0x28861f80]
[  9822.229] (EE) 15: /usr/local/lib/libGL.so.1 (_init+0x219b1) [0x288741a6]
[  9822.237] (EE) 16: /usr/local/bin/X (InitExtensions+0x6c) [0x80f2e88]
[  9822.244] (EE) 17: /usr/local/bin/X (remove_fs_handlers+0x34f) [0x807d83e]
[  9822.251] (EE) 18: /usr/local/bin/X (_start+0x23c) [0x8066308]
[  9822.258] (EE) 19: /usr/local/bin/X (_start+0x15a) [0x8066144]
[  9822.266] (EE) 20: /usr/local/bin/X (_start+0x18) [0x8065ea8]
[  9822.266] (EE)
[  9822.266] (EE) Segmentation fault at address 0x2f1c6000
[  9822.266] (EE)
Fatal server error:
[  9822.266] (EE) Caught signal 11 (Segmentation fault). Server aborting
[  9822.266] (EE)
[  9822.266] (EE)




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?alpine.BSF.2.20.1703072304290.1506>