Skip site navigation (1)Skip section navigation (2)
Date:      Tue, 20 Feb 2007 18:52:24 +0100
From:      Hans Nieser <h.nieser@xs4all.nl>
To:        freebsd-questions@freebsd.org
Subject:   Re: Unable to upgrade subversion 1.4.2 to 1.4.3 (apache22 db4 support)
Message-ID:  <45DB3558.3080607@xs4all.nl>
In-Reply-To: <45D67685.2090906@xs4all.nl>
References:  <45D67685.2090906@xs4all.nl>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
Hans Nieser wrote:
> Hi list,
> 
> I'm trying to upgrade subversion from 1.4.2 to 1.4.3 (as part of a full
> system update using 'portupgrade -a') but during compilation it aborts
> with the following message:
> 
>> You should build `www/apache22' with db4 support to use subversion with
>> it. Please rebuild `www/apache22' with option
>> `WITH_BERKELYDB=(db4|db41|db42)' and try again.
> 
> (or it suggests disabling db4 entirely with WITHOUT_DBD)
> 
> Since it doesn't seem like a bad idea to have the DB4 repository backend 
> available I decided to recompile apache22 (version 2.2.4) with DB4 
> support by adding the following to the MAKE_ARGS list in 
> /usr/local/etc/pkgtools.conf:
> 
>  > 'www/apache22' => 'WITH_BERKELYDB=db42',
> 

Problem solved now. I double checked several times, yet somehow I missed 
that I had written BERKELY instead of BERKELEY




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?45DB3558.3080607>