Skip site navigation (1)Skip section navigation (2)
Date:      Mon, 02 Jul 2007 15:37:25 +1000
From:      Joel Hatton <freebsd-questions@auscert.org.au>
To:        freebsd-questions@freebsd.org
Subject:   Re: Xorg build problem - font-misc-misc 
Message-ID:  <200707020537.l625bPYQ040386@app.auscert.org.au>
In-Reply-To: Your message of "Tue, 26 Jun 2007 08:50:10 -0400." <448xa6c22l.fsf@be-well.ilk.org> 

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
Hi,

I have solved this issue. Turned out that font-util wasn't properly
installed. Although I followed the steps in UPDATING, it appears that a
lot of my ports didn't cleanly/properly upgrade - what I found I had to
do was to repeatedly portupgrade -a, identify which ports stopped on 'you
should make deinstall/reinstall' type errors and individually do just that
for each one until no more errors ensued from portupgrade.  Then I had to
run portupgrade -N x11/xorg on top of that, as it appears that I didn't
previously have the x11/xorg meta-port installed. I find it curious that
although I had full X functionality before without it, just about
everything I needed now hinged on adding it.

Even after all of this, I keep finding that I have to add individual apps
as I need them ie base things like xauth still weren't installed until I
added them by hand afterwards.

joel

On Tue, 26 Jun 2007 08:50:10 -0400, Lowell Gilbert wrote:
>freebsd-questions@auscert.org.au writes:
>
>> I've _almost_ successfully upgraded to 7.2 xorg. For some reason, I'm
>> getting a failure when building font-misc-misc and this stops other crucial
>> ports getting built. At present, if I try to run 'X' I get the dreaded
>> "cannot find font fixed' error. I sync'd my ports tree again this morning
>> but the problem remained.
>>
>> Here's the output from the build error I get:
>>
>> /usr/local/bin/bdftopcf -t nil2.bdf | gzip > nil2.pcf.gz
>> 4x6.bdf /usr/local/lib/X11/fonts/util/map-ISO8859-1 ISO8859-1
>> 4x6.bdf:No such file or directory
>> *** Error code 1
>>
>> Stop in /usr/ports/x11-fonts/font-misc-misc/work/font-misc-misc-1.0.0.
>> *** Error code 1
>>
>> Stop in /usr/ports/x11-fonts/font-misc-misc.
>>
>> Help?
>
>That's weird.  The failure seems to be actually failing to find the
>font source in the port directory.  Is the port clean before building?   
>Is the file that it fails on present in the port directory at the time
>of failure?
>_______________________________________________
>freebsd-questions@freebsd.org mailing list
>http://lists.freebsd.org/mailman/listinfo/freebsd-questions
>To unsubscribe, send any mail to "freebsd-questions-unsubscribe@freebsd.org"



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?200707020537.l625bPYQ040386>