Skip site navigation (1)Skip section navigation (2)
Date:      Sun, 10 Dec 2017 17:34:28 -0700 (MST)
From:      Gary Aitken <garya@breakaway.dreamchaser.org>
To:        freebsd-questions@freebsd.org
Subject:   Thunderbird causing system crash, need guidance
Message-ID:  <201712110034.vBB0YSQK001198@breakaway.dreamchaser.org>

Next in thread | Raw E-Mail | Index | Archive | Help
Hi all,

Looking for guidance diagnosing a system crash caused by
attempting to start Thunderbird.

10.3-RELEASE-p20 FreeBSD 10.3-RELEASE-p20 #0: Wed Jul 12 03:13:07
UTC 2017     root@amd64-builder.daemonology.net:/usr/obj/usr
/src/sys/GENERIC  amd64

After running flawlessly for over a month, I started having
sluggish behavior.  Since this is a known problem with firefox
56, I exited and restarted it several times over the course of a
few days. Then yesterday (2017-12-08) the system hung and
crashed.

I have narrowed the cause down to Thunderbird 52.4.0, or at least
something associated with it.

The system + X seem to still run fine; openoffice, firefox, gimp.
When I attempt to start t-bird the cursor disappears almost
immediately, followed by a long wait with the display apparently
frozen, and then results in a crash and reboot.

It seems t-bird should crash/dump core without crashing the
system if it was just a t-bird problem, even if it's a bad binary
image?

I originally had crash dumps disabled, so changed
  dumpdev="NO" to "AUTO" in rc.conf
but still no dump in /var/crash
  only thing in /var/crash is minfree, which says "2048"
At reboot, I see the message
  "No suitable dump device was found"
so presumably that's the problem.
It may be my sys config, as /tmp and swap are memdisks.
The disk has no swap or tmp partition; I'm not sure how or if I
can modify fstab or the config to get swap on disk for a dump.
>From fstab:
  /dev/ufs/hd250G1root  /     ufs     rw,noatime      1       1
  /dev/ufs/hd250G1var   /var  ufs     rw,noatime      2       2
  /dev/ufs/hd250G1usr   /usr  ufs     rw,noatime      7       3
  tmpfs                 /tmp  tmpfs   rw,mode=01777   0       0
  md99                  none  swap    sw,file=/usr/swap/swap,late     0       0
/var is 16G

It seems like it may be corrupted disk data, but I'm wondering if
there's a good way to diagnose that.

In ~/.thunderbird/xxx.default (profile) directory, the last date
on a file is the "lock" symlink, from (I think) the first crash.
Other files show times 27 min earlier, which may be the last time
t-bird semi-successfully started up.
Interestingly, deleting the "lock" symlink and attempting to
restart t-bird results in the "lock" symlink being recreated with
the same (old!) timestamp, Dec 8 21:08.

There's a chance this is caused by an incompatible library;
I've rebuilt and updated several ports over the past month, and I
don't know if I restarted t-bird during that period.
But again, I would expect t-bird to crash but not the system.

Any and all thoughts welcome.

Thanks,

Gary



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?201712110034.vBB0YSQK001198>