Skip site navigation (1)Skip section navigation (2)
Date:      Tue, 15 Dec 2015 09:06:05 -0800 (PST)
From:      Anton Shterenlikht <mexas@bris.ac.uk>
To:        freebsd-questions@freebsd.org
Subject:   Sun Fire X4200 M2 - help fix console login
Message-ID:  <201512151706.tBFH64t0000926@mech-as222.men.bris.ac.uk>

Next in thread | Raw E-Mail | Index | Archive | Help
Hi

I've been through lots of oracle docs,
online help and mailing list archives.
Still can't make it work.
Just in case somebody is using
Sun Fire X4200 M2, asking here.

I can connect to ILOM via ethernet - no problem.
I can start a console and see boot process going on,
until the FreeBSD kernel starts to boot.
The last line I see is:

/boot/kernel/kernel text=0xfc8d88 data=0x1283b0+0x207880 syms=[0x8+0x145350|

After that nothing is appering at the console.
Eventually the boot process is complete and I can
login to the server via ssh.

I'm trying to get a console login, but can't.

Does this BIOS config look right?

* Configure Remote Access type and parameters         *
* *************************************************** *
* Remote Access                  [Enabled]            *
*                                                     *
* Serial port number             [COM1]               *
*      Base Address, IRQ         [3F8h, 4]            *
* Serial Port Mode               [09600 8,n,1]        *
* Flow Control                   [None]               *
* Redirection After BIOS POST    [Always]             *
* Terminal Type                  [ANSI]               *
* VT-UTF8 Combo Key Support      [Enabled]            *
* Sredir Memory Display Delay    [No Delay]           *                        


I'm particulary uncertain about "Redirection After BIOS POST".
The options are Disabled, Boot Loader and Always.
The on-screen help says:

Disable: Turns off the redirection after POST.

Boot Loader: Redirection is active during POST
and during Boot Loader.

Always: Redirection is always active.
 (Some OSs may not work if set to Always).

I'm not even clear about redirection of what to where?
It seems if I set Disabled or Boot loader I don't even
get to the FreeBSD kernel boot line. The console seems
to freeze some time prior to that. The boot still proceeds
ok, but no console login prompt is issued, only ssh login
is possible.

In /etc/ttys I have:

ttyu0   "/usr/libexec/getty std.9600"   vt100   onifconsole secure
ttyu1   "/usr/libexec/getty std.9600"   vt100   onifconsole secure
ttyu2   "/usr/libexec/getty std.9600"   vt100   onifconsole secure
ttyu3   "/usr/libexec/getty std.9600"   dialup  on secure

In dmesg:

$ dmesg | grep uart
uart0: <16550 or compatible> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
uart0: <16550 or compatible> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0

$ dmesg | grep tty
$ dmesg | grep cons
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>

Please advise

Thanks

Anton



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?201512151706.tBFH64t0000926>