Skip site navigation (1)Skip section navigation (2)
Date:      Sat, 25 Oct 2014 13:23:55 -0600
From:      Ian Lepore <ian@FreeBSD.org>
To:        John-Mark Gurney <jmg@funkthat.com>
Cc:        Mateusz Guzik <mjguzik@gmail.com>, freebsd-arch@freebsd.org
Subject:   Re: refcount_release_take_##lock
Message-ID:  <1414265035.12052.646.camel@revolution.hippie.lan>
In-Reply-To: <20141025190407.GU82214@funkthat.com>
References:  <20141025184448.GA19066@dft-labs.eu> <20141025190407.GU82214@funkthat.com>

next in thread | previous in thread | raw e-mail | index | archive | help
On Sat, 2014-10-25 at 12:04 -0700, John-Mark Gurney wrote:
> Mateusz Guzik wrote this message on Sat, Oct 25, 2014 at 20:44 +0200:
> > The following idiom is used here and there:
> > 
> > int old;
> > old = obj->ref;
> > if (old > 1 && atomic_cmpset_int(&obj->ref, old, old -1))
> > 	return;
> > lock(&something);
> > if (refcount_release(&obj->ref) == 0) {
> > 	unlock(&something);
> > 	return;
> > }
> > free up
> > unlock(&something);
> > 
> > ==========
> 
> Couldn't this be better written as:
> if (__predict_false(refcount_release(&obj->ref) == 0)) {

Could you not get preempted at this point, whereupon another thread
acquires then releases obj, deletes it because it keeps running through
this point, then eventually your original thread wakes up, gets the
lock, and dereferences the now-defunct obj pointer?

(Also, I think that should be != 0, above?)

-- Ian

> 	lock(&something);
> 	if (__predict_true(!obj->ref)) {
> 		free up
> 	}
> 	unlock(&something);
> }
> 
> The reason I'm asking is that I changed how IPsec SA ref counting was
> handled, and used something similar...
> 
> My code gets rid of a branch, and is better in that it uses refcount
> API properly, instead of using atomic_cmpset_int...
> 
> > I decided to implement it as a common function.
> > 
> > We have only refcount.h and I didn't want to bloat all including code
> > with additional definitions and as such I came up with a macro that has
> > to be used in .c file and that will define appropriate inline func.
> > 
> > I'm definitely looking for better names for REFCOUNT_RELEASE_TAKE_USE_
> > macro, assuming it has to stay.
> 
> You could shorten it to REFCNT_REL_TAKE_
> 
> > Comments?
> 
> Will you update the refcount(9) man page w/ documentation before
> committing?
> 





Want to link to this message? Use this URL: <https://mail-archive.FreeBSD.org/cgi/mid.cgi?1414265035.12052.646.camel>