Skip site navigation (1)Skip section navigation (2)
Date:      Sat, 24 Feb 2007 10:11:53 -0500
From:      Gerard Seibert <gerard@seibercom.net>
To:        freebsd-questions@freebsd.org
Subject:   Forcing correct version of Clamav to be installed
Message-ID:  <20070224101153.6b66fdc1@localhost>

Next in thread | Raw E-Mail | Index | Archive | Help
--Sig_In/xLlu.4H5rkwcu31M8tQG
Content-Type: text/plain; charset=US-ASCII
Content-Transfer-Encoding: quoted-printable

I recently contacted the maintainer of 'claws-mail' -- Alexander
Leidinger <netchild@FreeBSD.org> -- regarding a problem with that port.
It wants to install 'clamav' even though I have 'clamav-devel'
installed. Since these ports conflict, the install fails.

After talking to Alexander, he informs me that it is a generic problem
with the ports system and that it should be fixed there. I haven't got
the knowledge of how to accomplish this however. Instead, I modified
the claws-mail Makefile to have it install clamav-devel rather than
clamav. The problem is that portsnap will over write that change if and
when it updates the port requiring me to manually re-edit the Makefile.

My question is how would I proceed to force any port that wants to
install clamav to rather install clamav-devel? I have this problem with
other ports and having to manually edit each Makefile is an annoyance,
especially if I forget to make the changes.

--=20
Gerard

--Sig_In/xLlu.4H5rkwcu31M8tQG
Content-Type: application/pgp-signature; name=signature.asc
Content-Disposition: attachment; filename=signature.asc

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.2 (FreeBSD)

iD8DBQFF4FW5FCqdq4D1ybYRAl7sAJ9o1mie6MIGcuBUpY8qIAYBTi/0NgCg1Rfs
c39t2RYqJbOLR91SGXxaeNw=
=RAc2
-----END PGP SIGNATURE-----

--Sig_In/xLlu.4H5rkwcu31M8tQG--



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?20070224101153.6b66fdc1>