Skip site navigation (1)Skip section navigation (2)
Date:      Tue, 22 Sep 2009 08:58:16 +0200 (CEST)
From:      Pieter Donche <Pieter.Donche@ua.ac.be>
To:        "mail.list freebsd-questions" <freebsd-questions@freebsd.org>
Subject:   gtar-1.22_1, lzmautils-4.32.7 and xz-4.999.9
Message-ID:  <alpine.BSF.2.00.0909220853520.58905@macos.cmi.ua.ac.be>

Next in thread | Raw E-Mail | Index | Archive | Help
gtar-1.22_1, lzmautils-4.32.7 and xz-4.999.9

pkg_version -vIL= reported today as ports to upgrade:

gtar-1.22                           <   needs updating (index has 1.22_1)
librsvg2-2.26.0_1                   <   needs updating (index has 2.26.0_2)
lzmautils-4.32.7                    !   Comparison failed

I have lzmautils-4.32.7
$ pkg_info | grep lzmautils-4.32.7
lzmautils-4.32.7    LZMA compression and decompression tools

-- What does this  Comparaised failed mean ??

I started a portupgrade:
# portsnap fetch
# portsnap update
# portupgrade -yaRrpb | tee /tmp/portupgrade-mail

the output reports about gtar-1.22 :
...
===>   gtar-1.22_1 depends on executable: lzop - found
===>   gtar-1.22_1 depends on executable: xz - not found

xz-4.999.9beta.tar.gz  is fetched from http://tukaani.org/xz/
extracted and installed ...

===>  xz-4.999.9 conflicts with installed package(s):
       lzmautils-4.32.7

       They install files into the same place.
       Please remove them first with pkg_delete(1). 
*** Error code 1

Stop in /usr/ports/archivers/xz.
*** Error code 1

Stop in /usr/ports/archivers/gtar.
*** Error code 1

Stop in /usr/ports/archivers/gtar.
** Command failed [exit code 1]: /usr/bin/script -qa /tmp/portupgrade20090922-22
895-zz3ywq-0 env UPGRADE_TOOL=portupgrade UPGRADE_PORT=gtar-1.22 UPGRADE_PORT_VE
R=1.22 make DEPENDS_TARGET=package reinstall
--->  Updating dependency info
--->  Modifying /var/db/pkg/kde-3.5.10_2/+CONTENTS 
--->  Modifying /var/db/pkg/kdeutils-3.5.10_2/+CONTENTS
--->  Restoring the old version
--->  Keeping old package in '/usr/ports/packages/All'
** Fix the installation problem and try again.

Is xz-4.999.9  a complete replacement for package lzmautils-4.32.7
must I completely pkg_delete lzmautils-4.32.7 and never install it again?

Then retry portupgrade ?

Or what should I best do ?




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?alpine.BSF.2.00.0909220853520.58905>