Skip site navigation (1)Skip section navigation (2)
Date:      Wed, 29 Jun 2011 09:58:02 +0200
From:      "O. Hartmann" <ohartman@zedat.fu-berlin.de>
To:        freebsd-questions@FreeBSD.ORG, freebsd-stable@freebsd.org
Subject:   Dell PowerEdge 1950: MPT0 doesn't recogniz hard drive > 2TB
Message-ID:  <4E0ADB0A.2070409@zedat.fu-berlin.de>

Next in thread | Raw E-Mail | Index | Archive | Help
On a Dell PowerEdge 1950, BIOS from 2007, a freshly installed  WD 3 TB 
SATA 6GB harddrive doesn't get recognized as 3 TB disk, it is reported 
as 2TB disk only.

The box is running FreeBSD 8.2-STABLE (see below the dmesg excerpt). The 
drive is configured as ZFS pool on top of a GPT partition.

I tried the 3 TB harddrive on a FreeBSD 9.0-CURRENT box with Intel 
ICH10R SATA chipset and it worked fine, was reported as 2.7TB drive as 
expected.

I found some postings concerning mptutil not dealing with HD > 2TB, but 
this issue seems not to be a tool-issue.

Questions:
a) Is this an issue of FreeBSD 8.2-STABLE or is it a firmware/BIOS issue 
which can be solved?

b) regarding to a), how can I update the BIOS/MPT firmware of the Dell 
PowerEdge 1950? Is there an option to do this via USB? As I said, the 
firmware is quite old, it's from 2007.


Thanks in advance,

Oliver


==========================


Copyright (c) 1992-2011 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
         The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 8.2-STABLE #266 r223622: Tue Jun 28 09:38:38 CEST 2011
     root@thusnelda.geoinf.fu-berlin.de:/usr/obj/usr/src/sys/THUSNELDA amd64
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Intel(R) Xeon(R) CPU           E5420  @ 2.50GHz (2493.76-MHz 
K8-class CPU)
   Origin = "GenuineIntel"  Id = 0x10676  Family = 6  Model = 17 
Stepping = 6
 
Features=0xbfebfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE>
 
Features2=0xce3bd<SSE3,DTES64,MON,DS_CPL,VMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,DCA,SSE4.1>
   AMD Features=0x20100800<SYSCALL,NX,LM>
   AMD Features2=0x1<LAHF>
   TSC: P-state invariant
real memory  = 17179869184 (16384 MB)
avail memory = 16522498048 (15757 MB)
ACPI APIC Table: <DELL   PE_SC3  >
FreeBSD/SMP: Multiprocessor System Detected: 8 CPUs
FreeBSD/SMP: 2 package(s) x 4 core(s)
  cpu0 (BSP): APIC ID:  0
  cpu1 (AP): APIC ID:  1
  cpu2 (AP): APIC ID:  2
  cpu3 (AP): APIC ID:  3
  cpu4 (AP): APIC ID:  4
  cpu5 (AP): APIC ID:  5
  cpu6 (AP): APIC ID:  6
  cpu7 (AP): APIC ID:  7
ioapic0: Changing APIC ID to 8
ioapic0 <Version 2.0> irqs 0-23 on motherboard
kbd1 at kbdmux0
cryptosoft0: <software crypto> on motherboard
aesni0: No AESNI support.
acpi0: <DELL PE_SC3> on motherboard
acpi0: [ITHREAD]
acpi0: Power Button (fixed)
ipmi0: KCS mode found at io 0xca8 on acpi
ipmi0: KCS error: ff
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x808-0x80b on acpi0

[...]

mpt0: <LSILogic SAS/SATA Adapter> port 0xec00-0xecff mem 
0xfc4fc000-0xfc4fffff,0xfc4e0000-0xfc4effff irq 16 at device 0.0 on pci1
mpt0: [ITHREAD]
mpt0: MPI Version=1.5.14.0
mpt0: Capabilities: ( RAID-0 RAID-1E RAID-1 )
mpt0: 0 Active Volumes (2 Max)
mpt0: 0 Hidden Drive Members (14 Max)

[...]

ipmi0: IPMI device rev. 0, firmware rev. 2.10, version 2.0
ipmi0: Number of channels 4
ipmi0: Attached watchdog
da0 at mpt0 bus 0 scbus0 target 0 lun 0
da0: <ATA Hitachi HUA72107 A74A> Fixed Direct Access SCSI-5 device
da0: 300.000MB/s transfers
da0: Command Queueing enabled
da0: 715404MB (1465149168 512 byte sectors: 255H 63S/T 91201C)
da1 at mpt0 bus 0 scbus0 target 1 lun 0
da1: <ATA WDC WD30EZRX-00M 0A80> Fixed Direct Access SCSI-5 device
da1: 300.000MB/s transfers
da1: Command Queueing enabled
da1: 2097151MB (4294967295 512 byte sectors: 255H 63S/T 267349C)
ses0 at mpt0 bus 0 scbus0 target 8 lun 0
ses0: <DP BACKPLANE 1.05> Fixed Enclosure Services SCSI-5 device
ses0: 300.000MB/s transfers
ses0: SCSI-3 SES Device
cd0 at ata0 bus 0 scbus2 target 0 lun 0SMP: AP CPU #3 Launched!
cd0:
<TEAC DVD-ROM DV28EV D.AE> Removable CD-ROM SCSI-0 device
cd0: 33.300MB/s transfers (UDMA2, ATAPI 12bytes, PIO 65534bytes)
cd0: Attempt to query device size failed: NOT READY, Medium not present 
- tray closed
SMP: AP CPU #1 Launched!
SMP: AP CPU #2 Launched!
SMP: AP CPU #7 Launched!
SMP: AP CPU #4 Launched!
SMP: AP CPU #6 Launched!
SMP: AP CPU #5 Launched!





Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?4E0ADB0A.2070409>