Skip site navigation (1)Skip section navigation (2)
Date:      Mon, 6 Aug 2007 12:09:28 -0500
From:      Novembre <novembre@gmail.com>
To:        "Michael Nottebrock" <lofi@freebsd.org>
Cc:        freebsd-x11@freebsd.org, freebsd-questions@freebsd.org
Subject:   Re: keyboard layout change in Xorg 7.2
Message-ID:  <3b47caa90708061009h6a61b7c4s78bf821ad8a9a077@mail.gmail.com>
In-Reply-To: <46B72F85.70205@freebsd.org>
References:  <3b47caa90708041410s30f87f52g4d928c928e5f0eb0@mail.gmail.com> <46B72F85.70205@freebsd.org>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On 8/6/07, Michael Nottebrock <lofi@freebsd.org> wrote:
>
> Novembre schrieb:
> > I have Xfce 4.4.1_1 on top of X.org 7.2 running on FreeBSD
> > 6.2-RELEASEinstalled on a Pentium III-S
> > 1.4GHz machine.
> > The problem is that the ALT keys are not working when using XkbLayout
> option
> > in xorg.conf when I put the following lines in /etc/X11/xorg.conf:
> >
> > Option     "XkbLayout"     "us,ir"
> > Option     "XkbOptions"    "grp:alt_shift_toggle"
> >
> > With these options, single ALT keys do not work, and I mean not just in
> > changing the keyboard layout, but anywhere! For example, ALT-TAB which
> > should change the current window does not work anymore. I have found out
> > that in this case, i.e. using XkbLayout option, if I press both ALT keys
> at
> > the same time, it'll do work! So, LEFTALT-RIGHTALT-TAB changes the
> current
> > window, and LEFTALT-RIGHTALT-SHIFT changes the layout. I have no idea
> why,
> > and I see no reason why, since I told X that the layout needs to be
> changed
> > when I press only ONE of the ALT keys (and I have not mentioned which
> one,
> > so both should be okay) and the SHIFT key. It's very troublesome, and I
> > don't want to hold down both ALTs instead of just one of them. The same
> > setting used to work when I was using Xfce 4.2 on top of X.org 6.9.
> > Any ideas?
> >
> Are you running the latest version of the x11/xkeyboard-config port
> (1.0_1)? The most recent update fixed a number of isses related to
> keyboard layouts. (See
>
> http://www.freebsd.org/cgi/getmsg.cgi?fetch=947832+0+/usr/local/www/db/text/2007/cvs-ports/20070729.cvs-ports
> ).
>
> Cheers,
> --
>    ,_,   | Michael Nottebrock               | lofi@freebsd.org
> (/^ ^\) | FreeBSD - The Power to Serve     | http://www.freebsd.org
>    \u/   | K Desktop Environment on FreeBSD | http://freebsd.kde.org
>
>
>
>

Thanks so much. I did a 'portupgrade xkeyboard-config' to the latest
version, and that fixed the problem.



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?3b47caa90708061009h6a61b7c4s78bf821ad8a9a077>