Skip site navigation (1)Skip section navigation (2)
Date:      Mon, 2 Jul 2007 20:09:47 +0200
From:      Nikola Lecic <nlecic@EUnet.yu>
To:        Graham Bentley <admin@cpcnw.co.uk>
Cc:        tevans.uk@googlemail.com, freebsd-questions@freebsd.org, freebsd-gnome@freebsd.org
Subject:   Re: Selecting printer from apps core dumps. Howto debug?
Message-ID:  <200707021809.l62I9P9k009029@smtpclu-1.eunet.yu>
In-Reply-To: <20070630220658.74f7174d@3bsd.cpcnw.co.uk>
References:  <20070630220658.74f7174d@3bsd.cpcnw.co.uk>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
(I proposed you a couple of things but generally it's a good idea to
ask this on freebsd-gnome@ as well, since at least the Abiword problem
is _maybe_ related to libgnomeprintui <-> Xfce.)

On Sat, 30 Jun 2007 22:06:58 +0100
Graham Bentley <admin@cpcnw.co.uk> wrote:

> > have you compiled print/xfce4-print with "Use cups as
> > printing system"? This matters, among other things. You=20
> > can check it with 'make showconfig' and change with=20
> > 'make config'.
>=20
> 3bsd# make showconfig
> =3D=3D=3D> The following configuration options are available for
> xfce4-print-4.4.1_1: LPR=3Doff "Use lpr as printing system"
>      CUPS=3Don "Use cups as printing system"
>      LETTER=3Doff "Use letter paper format instead of A4"
> =3D=3D=3D> Use 'make config' to modify these settings
> 3bsd#

Ok...

> Its odd because the cups test page works, printing from
> mousepad and firefox works, but abiword bombs completely.
> In the short space of time I see it on the screen after=20
> clicking print I can see there is no entry for the printer.

AFAIK Abiword has known (and very old) problem with Xfce, mainly
reflected in printing. As far as I understand it (I use neither Abiword
nor CUPS) the cause could be the Abiword's (false) expectations of pure
GNOME environment (including printing), which is only partially true in
Xfce. You can try this, but I have no idea what can happen:

  # portupgrade -f -m 'WANT_GNOME=3Dno' abiword

Besides that, Claws Mail has by default similar expectations regarding
printing (libgnomeprintui). Do you have printing problems in Claws
Mail? Can you post here 'make showconfig" of mail/claws-mail?

> > I had similar problems until I removed lpr from the base.
> > To do this, I added this to /etc/make.conf:
> > WITHOUT_LPR=3Dtrue
> > CUPS_OVERWRITE_BASE=3Dyes
> > NO_LPR=3Dyes
> > and then rebuilt and reinstalled world and cups.
>
> I have tried adding lpd_enable=3D"NO" top rc.conf then realised
> cups replaces lpd anyway so that was no help.
>=20
> Somewhere along the line I have added
>=20
> [system=3D10]
> add path 'unlpt*' mode 0660 group cups
> add path 'ulpt*' mode 0660 group cups
> add path 'lpt*' mode 0660 group cups
>=20
> to /etc/devfs.rules and
>=20
> devfs_system_ruleset=3D"system"
>=20
> to rc.conf
>=20
> I wanted to avoid having to buildword just now ...
>=20
> and just read this thead ;
>=20
> > CUPS installs its own version of lpr, lpq and lpd
> > under /usr/local/bin.
> > Therefore, be sure to delete lpr , lpq and lpd under=20
> > /usr/bin and then symlink from /usr/local/bin to /usr/bin.
>=20
> although lpd looks to be under /usr/sbin on my system?

You certainly shouldn't do this kind of random handiwork in your system.

Nikola Le=C4=8Di=C4=87



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?200707021809.l62I9P9k009029>