Skip site navigation (1)Skip section navigation (2)
Date:      Wed, 4 Jun 1997 08:29:02 +1000 (EST)
From:      Iain Templeton <iaint@CU-SeeMe.educ.utas.edu.au>
To:        Jason DeFillippo <jason@spewww.com>
Cc:        freebsd-questions@FreeBSD.ORG
Subject:   Re: Major PERL problem
Message-ID:  <Pine.BSF.3.95q.970604082448.25960A-100000@CU-SeeMe.educ.utas.edu.au>
In-Reply-To: <v03102805afba1896027d@[207.211.110.30]>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Tue, 3 Jun 1997, Jason DeFillippo wrote:

> use <package name>;
> 
> This is using the straight off the FreeBSD CD PERL install. Anybody have
> any clue as to why this is happening???? I need to use the GD library and I
> can't with this happening.
> 
It could be that you are using perl v4 (try perl -v), /usr/bin/perl is
perl 4 normally, and you will have to install perl5 to be able to use
um... 'use'. 

The perl5 port/package in lang/perl5 I think would solve your problem.

If you have already installed perl 5, it is by default installed as
/usr/local/bin/perl, but /usr/bin/perl is (normally for me) in the
path before it, so perl 4 gets called.

Iain. 





Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?Pine.BSF.3.95q.970604082448.25960A-100000>