Skip site navigation (1)Skip section navigation (2)
Date:      Mon, 11 Dec 2017 20:48:38 +0000
From:      Vitalio D <v.dol_s@hotmail.com>
To:        Polytropon <freebsd@edvax.de>, "steve@sohara.org" <steve@sohara.org>
Cc:        "freebsd-questions@freebsd.org" <freebsd-questions@freebsd.org>
Subject:   Re: vt(4) iso-8859-1 latin accentuated characters do not show on console
Message-ID:  <AM5PR0902MB1923C0A5EC84393214E84CC6DC370@AM5PR0902MB1923.eurprd09.prod.outlook.com>
In-Reply-To: <20171211212252.e403c4d2.freebsd@edvax.de>
References:  <AM5PR0902MB1923F0EC5C436D9FDB0E637DDC370@AM5PR0902MB1923.eurprd09.prod.outlook.com>, <20171211212252.e403c4d2.freebsd@edvax.de>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
Hello, Polytropon, Steve

Thank you guys for your help. I've figured it out finally.
So to use vt(4) with accented west European glyphs I had to do the followin=
g
in ~/.login_conf

me:\
    :charset=3DUTF-8:

in rc.conf
keymap=3Dfr.acc

Steve, yes the handbook I was trying to read is fr_FR.ISO8859-1. There is n=
o fr_FR.UTF-8 handbook unfortunately (at least did not find on svn).
Also should the handbook (the i18l section) be updated since vt(4) is defau=
lt driver?

________________________________________
From: Polytropon <freebsd@edvax.de>
Sent: Monday, December 11, 2017 8:22:52 PM
To: Vitalio D
Cc: freebsd-questions@freebsd.org
Subject: Re: vt(4) iso-8859-1 latin accentuated characters do not show on c=
onsole

On Mon, 11 Dec 2017 14:28:52 +0000, Vitalio D wrote:
> I'm running 11.1-STABLE snapshot from November. By default my
> vty driver is vt(4) as seen from
> sysctl kern.vty
> kern.vty=3Dvt
>
> I've tried to configure french keyboard so to be able to see and
> type accentuated characters, but could not succeed.
>
> I've amended ~/.login_conf with
> me:\
>     :charset=3DISO-8859-1:\
>    :lang=3Dfr_FR.ISO-8859-1:
>
> but to no avail.
> The only solution I've found is to switch to sc(4) in /boot/loader.conf
>
> So my question is: should i file a bug ?

Definitely. I have the same problem with vt and de_DE.ISO8859-1
if I want to use the Umlauts =F6 =E4 =FC =D6 =C4 =DC and Eszett =DF. This i=
s
one of the cases where vt cannot do what sc could do for decades.

Maybe a workaround for you is this:

Set fr_FR.UTF-8 and check if you get the correct accents on
the vowels (or just "escaped unprintable" representation).

However, according to _my_ documentation the setting does not
have a 2nd "-" in it, not fr_FR.ISO-8859-1, but fr_FR.ISO8859-1
(only one "-") should be used. Maybe you can try this as well?


--
Polytropon
Magdeburg, Germany
Happy FreeBSD user since 4.0
Andra moi ennepe, Mousa, ...



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?AM5PR0902MB1923C0A5EC84393214E84CC6DC370>