Skip site navigation (1)Skip section navigation (2)
Date:      Fri, 04 May 2018 19:19:56 -0400
From:      StariKarp <starikarp@yandex.com>
To:        Shane Ambler <FreeBSD@ShaneWare.Biz>, FreeBSD Questions <freebsd-questions@freebsd.org>
Subject:   Re: blender - llvm
Message-ID:  <1525475996.74415.1.camel@yandex.com>
In-Reply-To: <11423618-016d-50ee-c420-4858f1221229@ShaneWare.Biz>
References:  <1524996990.23915.1.camel@yandex.com> <11423618-016d-50ee-c420-4858f1221229@ShaneWare.Biz>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Sat, 2018-05-05 at 02:55 +0930, Shane Ambler wrote:
> On 29/04/2018 19:46, StariKarp wrote:
> > Hi!
> > 
> > I am using Blender on FreeBSD 11.1-RELEASE (amd64) and as I have
> > experience it was (is) the problem with different versions of llvm
> > which new versions are coming in the ports tree very fast.
> > I have in /etc/make.conf:
> > MESA_LLVM_VER=40
> > and building and running Blender works. How is the future of
> > Blender
> > because of the new versions of llvm60, please?
> 
> I'm running 11-stable (Mar 16), I haven't updated during the start of
> the 11-stable changes preparing for 11.2
> 
> While I haven't done a full ports update for a while, (my
> dependencies
> are still built from llvm50), I can build blender using clang60 and
> aren't seeing any issues, that is with osl using llvm40.
> 
> In poudriere everything builds with llvm60
> 

Thank you. It works and as you wrote the problem is osl which I have to
used but cycles engine works without osl too.




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?1525475996.74415.1.camel>