Skip site navigation (1)Skip section navigation (2)
Date:      Sun, 22 Dec 2013 10:25:11 -0500
From:      "Mike." <the.lists@mgm51.com>
To:        freebsd-questions@freebsd.org
Subject:   [10.0RC2] partition labels during install
Message-ID:  <201312221025110645.0060D808@smtp.24cl.home>

Next in thread | Raw E-Mail | Index | Archive | Help

I just installed 10.0RC2 on a test notebook (dmesg at the end of
this message) to start becoming familiar with the changes it
brings.

During the install, while I was in the Guided partitioning part
of the install, I specified a label for each of the partitions
to be created.  (I suspect this feature was available in earlier
versions, but this is the first time I've used it)

After carefully typing the various labels into the install
screen, I then completed the install process and allowed the box
to reboot.

My next step was to check fstab to see if the labels had taken
hold.  This is what I saw:



# cat /etc/fstab 
# Device        Mountpoint      FStype  Options Dump    Pass#
/dev/ada0p2     /               ufs     rw      1       1
/dev/ada0p3     none            swap    sw      0       0
/dev/ada0p4     /var            ufs     rw      2       2
/dev/ada0p5     /tmp            ufs     rw      2       2
/dev/ada0p6     /usr            ufs     rw      2       2




Hmmm... so then I checked to see if the labels had been created
in /dev



# ls -al /dev/lab*  
ls: /dev/lab*: No such file or directory




So now I have the question --- what is the purpose of allowing
me to type in labels during the install process?  Where do they
"show up" after the install is complete?


Thanks.




dmesg (ThinkPad A31p)


Copyright (c) 1992-2013 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992,
1993, 1994
        The Regents of the University of California. All rights
reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 10.0-RC2 #0 r259404: Sun Dec 15 11:45:13 UTC 2013
    root@snap.freebsd.org:/usr/obj/usr/src/sys/GENERIC i386
FreeBSD clang version 3.3 (tags/RELEASE_33/final 183502)
20130610
CPU: Intel(R) Pentium(R) 4 Mobile CPU 1.70GHz (1698.61-MHz
686-class CPU)
  Origin = "GenuineIntel"  Id = 0xf24  Family = 0xf  Model = 0x2
 Stepping = 4
  Features=0x3febf9ff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,SEP,MTRR
,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT
,TM>
real memory  = 1073741824 (1024 MB)
avail memory = 1029230592 (981 MB)
kbd1 at kbdmux0
random: <Software, Yarrow> initialized
acpi0: <IBM TP-1G> on motherboard
acpi_ec0: <Embedded Controller: GPE 0x1c, ECDT> port 0x62,0x66
on acpi0
acpi0: Power Button (fixed)
acpi0: reservation of 0, a0000 (3) failed
acpi0: reservation of 100000, 3ff00000 (3) failed
cpu0: <ACPI CPU> on acpi0
attimer0: <AT timer> port 0x40-0x43 irq 0 on acpi0
Timecounter "i8254" frequency 1193182 Hz quality 0
Event timer "i8254" frequency 1193182 Hz quality 100
atrtc0: <AT realtime clock> port 0x70-0x71 irq 8 on acpi0
Event timer "RTC" frequency 32768 Hz quality 0
Timecounter "ACPI-safe" frequency 3579545 Hz quality 850
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x1008-0x100b on
acpi0
acpi_lid0: <Control Method Lid Switch> on acpi0
acpi_button0: <Sleep Button> on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
agp0: <Intel 82845 host to AGP bridge> on hostb0
pcib1: <ACPI PCI-PCI bridge> at device 1.0 on pci0
pci1: <ACPI PCI bus> on pcib1
vgapci0: <VGA-compatible display> port 0x3000-0x30ff mem
0xe8000000-0xefffffff,0xd0100000-0xd010ffff irq 11 at device 0.0
on pci1
uhci0: <Intel 82801CA/CAM (ICH3) USB controller USB-A> port
0x1800-0x181f irq 11 at device 29.0 on pci0
usbus0 on uhci0
uhci1: <Intel 82801CA/CAM (ICH3) USB controller USB-B> port
0x1820-0x183f irq 11 at device 29.1 on pci0
usbus1 on uhci1
uhci2: <Intel 82801CA/CAM (ICH3) USB controller USB-C> port
0x1840-0x185f irq 11 at device 29.2 on pci0
usbus2 on uhci2
pcib2: <ACPI PCI-PCI bridge> at device 30.0 on pci0
pci2: <ACPI PCI bus> on pcib2
cbb0: <RF5C476 PCI-CardBus Bridge> mem 0x50000000-0x50000fff irq
11 at device 0.0 on pci2
cardbus0: <CardBus bus> on cbb0
pccard0: <16-bit PCCard bus> on cbb0
cbb1: <RF5C476 PCI-CardBus Bridge> mem 0x50100000-0x50100fff irq
11 at device 0.1 on pci2
cardbus1: <CardBus bus> on cbb1
pccard1: <16-bit PCCard bus> on cbb1
pci2: <serial bus, FireWire> at device 0.2 (no driver attached)
fxp0: <Intel 82801CAM (ICH3) Pro/100 VE Ethernet> port
0x8000-0x803f mem 0xd0200000-0xd0200fff irq 11 at device 8.0 on
pci2
miibus0: <MII bus> on fxp0
inphy0: <i82562ET 10/100 media interface> PHY 1 on miibus0
inphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto,
auto-flow
fxp0: Ethernet address: 00:0e:9b:2c:c7:f6
isab0: <PCI-ISA bridge> at device 31.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <Intel ICH3 UDMA100 controller> port
0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0x1860-0x186f at device 31.1
on pci0
ata0: <ATA channel> at channel 0 on atapci0
ata1: <ATA channel> at channel 1 on atapci0
pci0: <serial bus, SMBus> at device 31.3 (no driver attached)
pcm0: <Intel ICH3 (82801CA)> port 0x1c00-0x1cff,0x18c0-0x18ff
irq 11 at device 31.5 on pci0
pcm0: <Analog Devices AD1881A AC97 Codec>
pci0: <simple comms, generic modem> at device 31.6 (no driver
attached)
acpi_tz0: <Thermal Zone> on acpi0
atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on
acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: [GIANT-LOCKED]
psm0: model Generic PS/2 mouse, device ID 0
fdc0: <floppy drive controller (FDE)> port 0x3f0-0x3f5,0x3f7 irq
6 drq 2 on acpi0
uart0: <16550 or compatible> port 0x3f8-0x3ff irq 4 flags 0x10
on acpi0
ppc0: <Parallel port> port 0x3bc-0x3be,0x7bc-0x7be irq 7 drq 0
on acpi0
ppc0: Generic chipset (ECP/PS2/NIBBLE) in COMPATIBLE mode
ppbus0: <Parallel port bus> on ppc0
ppi0: <Parallel I/O> on ppbus0
battery0: <ACPI Control Method Battery> on acpi0
acpi_acad0: <AC Adapter> on acpi0
pmtimer0 on isa0
orm0: <ISA Option ROMs> at iomem
0xc0000-0xcffff,0xdc000-0xdffff,0xe0000-0xeffff pnpid ORM0000 on
isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem
0xa0000-0xbffff on isa0
acpi_perf0: <ACPI CPU Frequency Control> on cpu0
p4tcc0: <CPU Frequency Thermal Control> on cpu0
Timecounters tick every 1.000 msec
random: unblocking device.
usbus0: 12Mbps Full Speed USB v1.0
usbus1: 12Mbps Full Speed USB v1.0
usbus2: 12Mbps Full Speed USB v1.0
ugen1.1: <Intel> at usbus1
uhub0: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1>
on usbus1
ugen0.1: <Intel> at usbus0
uhub1: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1>
on usbus0
ugen2.1: <Intel> at usbus2
uhub2: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1>
on usbus2
uhub0: 2 ports with 2 removable, self powered
uhub1: 2 ports with 2 removable, self powered
uhub2: 2 ports with 2 removable, self powered
ugen1.2: <vendor 0x1a40> at usbus1
uhub3: <vendor 0x1a40 USB 2.0 Hub, class 9/0, rev 2.00/1.11,
addr 2> on usbus1
uhub3: 4 ports with 4 removable, self powered
ugen1.3: <USB 2.0> at usbus1
umass0: <USB 2.0 Flash Disk, class 0/0, rev 2.00/11.00, addr 3>
on usbus1
umass0:  SCSI over Bulk-Only; quirks = 0x4000
umass0:2:0:-1: Attached to scbus2
ugen1.4: <USB 2.0> at usbus1
umass1: <USB 2.0 Flash Disk, class 0/0, rev 2.00/11.00, addr 4>
on usbus1
umass1:  SCSI over Bulk-Only; quirks = 0x4000
umass1:3:1:-1: Attached to scbus3
ugen1.5: <USB 2.0> at usbus1
umass2: <USB 2.0 Flash Disk, class 0/0, rev 2.00/11.00, addr 5>
on usbus1
umass2:  SCSI over Bulk-Only; quirks = 0x4000
umass2:4:2:-1: Attached to scbus4
ugen1.6: <USB 2.0> at usbus1
umass3: <USB 2.0 Flash Disk, class 0/0, rev 2.00/11.00, addr 6>
on usbus1
umass3:  SCSI over Bulk-Only; quirks = 0x4000
umass3:5:3:-1: Attached to scbus5
(aprobe0:ata1:0:1:0): ATAPI_IDENTIFY. ACB: a1 00 00 00 00 40 00
00 00 00 00 00
(aprobe0:ata1:0:1:0): CAM status: Command timeout
(aprobe0:ata1:0:1:0): Error 5, Retry was blocked
run_interrupt_driven_hooks: still waiting after 60 seconds for
xpt_config
(aprobe0:ata1:0:1:0): ATAPI_IDENTIFY. ACB: a1 00 00 00 00 40 00
00 00 00 00 00
(aprobe0:ata1:0:1:0): CAM status: Command timeout
(aprobe0:ata1:0:1:0): Error 5, Retry was blocked
ada0 at ata0 bus 0 scbus0 target 0 lun 0
ada0: <HTS721080G9AT00 MC4OA51A> ATA-6 device
ada0: Serial Number MPC412Y4G6J1AE
ada0: 100.000MB/s transfers (UDMA5, PIO 8192bytes)
ada0: 76319MB (156301488 512 byte sectors: 16H 63S/T 16383C)
ada0: Previously was known as ad0
da0 at umass-sim0 bus 0 scbus2 target 0 lun 0
da0: <USB 2.0 Flash Disk 1100> Removable Direct Access SCSI-0
device 
da0: Serial Number AA40000000003835
da0: 1.000MB/s transfers
da0: 967MB (1981440 512 byte sectors: 64H 32S/T 967C)
da0: quirks=0x3<NO_SYNC_CACHE,NO_6_BYTE>
da1 at umass-sim1 bus 1 scbus3 target 0 lun 0
da1: <USB 2.0 Flash Disk 1100> Removable Direct Access SCSI-0
device 
da1: Serial Number AA40000000003840
da1: 1.000MB/s transfers
da1: 967MB (1981440 512 byte sectors: 64H 32S/T 967C)
da1: quirks=0x3<NO_SYNC_CACHE,NO_6_BYTE>
da2 at umass-sim2 bus 2 scbus4 target 0 lun 0
da2: <USB 2.0 Flash Disk 1100> Removable Direct Access SCSI-0
device 
da2: Serial Number AA40000000003903
da2: 1.000MB/s transfers
da2: 967MB (1981440 512 byte sectors: 64H 32S/T 967C)
da2: quirks=0x3<NO_SYNC_CACHE,NO_6_BYTE>
da3 at umass-sim3 bus 3 scbus5 target 0 lun 0
da3: <USB 2.0 Flash Disk 1100> Removable Direct Access SCSI-0
device 
da3: Serial Number AA40000000003941
da3: 1.000MB/s transfers
da3: 967MB (1981440 512 byte sectors: 64H 32S/T 967C)
da3: quirks=0x3<NO_SYNC_CACHE,NO_6_BYTE>
cd0 at ata1 bus 0 scbus1 target 0 lun 0
cd0: <MATSHITA UJDA720 DVD/CDRW 1.03> Removable CD-ROM SCSI-0
device 
cd0: 33.300MB/s transfers (UDMA2, ATAPI 12bytes, PIO 65534bytes)
cd0: cd present [289076 x 2048 byte records]
GEOM: da1: the secondary GPT header is not in the last LBA.
GEOM: da3: the secondary GPT header is not in the last LBA.
GEOM: diskid/DISK-AA40000000003840: the secondary GPT header is
not in the last LBA.
GEOM: diskid/DISK-AA40000000003941: the secondary GPT header is
not in the last LBA.
Trying to mount root from ufs:/dev/ada0p2 [rw]...





Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?201312221025110645.0060D808>