Skip site navigation (1)Skip section navigation (2)
Date:      Wed, 31 Oct 2012 05:25:11 -0400
From:      "Thomas Mueller" <mueller23@insightbb.com>
To:        freebsd-questions@freebsd.org
Cc:        Ewald Jenisch <a@jenisch.at>
Subject:   Re: yelp could not be built because of libxul dependency (10.0 vs. <2)
Message-ID:  <37.30.17144.77EE0905@smtp01.insight.synacor.com>

Next in thread | Raw E-Mail | Index | Archive | Help
from Ewald Jenisch <a@jenisch.at>:

> I'm trying to get my system up2date using portupgrade as usual.
> However during the upgrade process I ran into a problem during upgrade
> of yelp:

> ===>   yelp-2.30.2_4 depends on package: libxul<2 - not found
> ===>   Found libxul-10.0.10, but you need to upgrade to libxul<2.

> UPDATING has an entry for www/libxul of 20120910 that says

> "...If you want to stay with 1.9.2..."

> So in order to make yelp build again, does this mean I've got to
> de-install libxul-10.0.10 and install /usr/ports/www/libxul19 again?

> Thanks much in advance for your help,
> -ewald

I posted a message on this same issue with gnash and mentioned also yelp.

In the case of gnash, libxul19 is supposed to install a file
/usr/local/lib/libxul/xpidl
but libxul-10.0.9 doesn't.

Maybe the yelp port wants/needs this file too?

That was only a few days ago, maybe libxul was updated to 10.0.10 just a day
or two ago?

libxul19 wouldn't install, both because of conflict with libxul and because
libxul19 was marked vulnerable.

So I appear stuck until they fix this bug.  File a bug report?

Tom



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?37.30.17144.77EE0905>