Skip site navigation (1)Skip section navigation (2)
Date:      Mon, 18 Jul 2011 18:23:30 +0200
From:      Roland Smith <rsmith@xs4all.nl>
To:        Tim Daneliuk <tundra@tundraware.com>
Cc:        FreeBSD Mailing List <freebsd-questions@freebsd.org>
Subject:   Re: Am I Missing A Compat Library?
Message-ID:  <20110718162330.GA88138@slackbox.erewhon.net>
In-Reply-To: <4E244D20.6060401@tundraware.com>
References:  <4E244D20.6060401@tundraware.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help

--IS0zKkzwUGydFO0o
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

On Mon, Jul 18, 2011 at 10:11:28AM -0500, Tim Daneliuk wrote:
> I just ran pkg_libchk and got this:
>=20
>   avahi-app-0.6.29: /usr/local/lib/libavahi-glib.so.1 misses libicui18n.s=
o.46
>=20
> As I've never seen this before, I'm unclear on what to do to remmediate.

Have you updated your ports recently? The ICU port was updated to version 4=
=2E8
recently, which provides libicui18n.so.48, and replaced libicui18n.so.46. As
noted in /usr/ports/UPDATING, all ports that depend on ICU should be update=
d.

For some unknown reason this dependency was not resolved when you updated y=
our
ports.

Recompile the avahi-app port and it should link with the newer version and
work fine again.

Roland
--=20
R.F.Smith                                   http://www.xs4all.nl/~rsmith/
[plain text _non-HTML_ PGP/GnuPG encrypted/signed email much appreciated]
pgp: 1A2B 477F 9970 BA3C 2914  B7CE 1277 EFB0 C321 A725 (KeyID: C321A725)

--IS0zKkzwUGydFO0o
Content-Type: application/pgp-signature

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.17 (FreeBSD)

iEYEARECAAYFAk4kXgIACgkQEnfvsMMhpyUj+ACgolr/Pv50ARo78WBof54gB66w
9McAni6b7IrK18KsxejlhSGF3ZAemoz5
=dL85
-----END PGP SIGNATURE-----

--IS0zKkzwUGydFO0o--



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?20110718162330.GA88138>