Skip site navigation (1)Skip section navigation (2)
Date:      Tue, 08 Dec 2009 22:51:40 +0100
From:      Beat Siegenthaler <beat.siegenthaler@beatsnet.com>
To:        freebsd-questions@freebsd.org
Subject:   bridge "filters" ipv6
Message-ID:  <4B1ECA6C.8050709@beatsnet.com>

Next in thread | Raw E-Mail | Index | Archive | Help
Hi all,

I have 7.2-RELEASE  and a bridge between ath0 and sis0 everything works 
fine except  ipv6  including router advertisements.
There is no filtering, just  a L2 bridge without any address. rtadv 
comes from lan/sis. What could be missing?


bridge0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 
1500
        ether 0a:03:b2:xx:fe:xx
        id 00:00:00:00:00:00 priority 32768 hellotime 2 fwddelay 15
        maxage 20 holdcnt 6 proto rstp maxaddr 100 timeout 1200
        root id 00:00:00:00:00:00 priority 32768 ifcost 0 port 0
        member: sis0 flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>
                ifmaxaddr 0 port 2 priority 128 path cost 200000
        member: ath0 flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>
                ifmaxaddr 0 port 1 priority 128 path cost 370370


ath0: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 
0 mtu 1500
        ether 00:80:48:xx:cd:xx
        inet6 fe80::280:48xx:fexx:xxxx%ath0 prefixlen 64 scopeid 0x1
        media: IEEE 802.11 Wireless Ethernet autoselect mode 11g <hostap>
        status: associated
        ssid xxxxxxxxx channel 11 (2462 Mhz 11g) bssid 00:80:48:xx:cd:xx
        authmode WPA1+WPA2/802.11i privacy MIXED deftxkey 2 TKIP 2:128-bit
        txpower 22 scanvalid 60 bgscan bgscanintvl 300 bgscanidle 250
        roam:rssi11g 7 roam:rate11g 5 pureg protmode RTSCTS wme burst
        dtimperiod 1

sis0: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 
0 mtu 1500
        options=8<VLAN_MTU>
        ether 00:0d:b9:xx:52:xx
        inet6 fe80::20d:b9ff:fe03:52fc%sis0 prefixlen 64 scopeid 0x2
        inet 172.23.0.1 netmask 0xffffff00 broadcast 172.20.0.255
        media: Ethernet autoselect (100baseTX <full-duplex>)
        status: active





Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?4B1ECA6C.8050709>