Skip site navigation (1)Skip section navigation (2)
Date:      Sat, 10 Sep 2016 18:51:08 +0000
From:      Manish Jain <bourne.identity@hotmail.com>
To:        Polytropon <freebsd@edvax.de>
Cc:        freebsd-questions <freebsd-questions@freebsd.org>
Subject:   Re: Will installing a separate sound card work?
Message-ID:  <VI1PR02MB09746666CAC50D3EB42D2698F6FD0@VI1PR02MB0974.eurprd02.prod.outlook.com>
In-Reply-To: <20160910201746.e62bd384.freebsd@edvax.de>
References:  <VI1PR02MB0974245A63E0A5938C14B131C2FD0@VI1PR02MB0974.eurprd02.prod.outlook.com> <20160910201746.e62bd384.freebsd@edvax.de>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On 09/10/16 23:47, Polytropon wrote:
> On Sat, 10 Sep 2016 17:48:23 +0000, Manish Jain wrote:
>> In my computer hardware upgrade project (which has already seen me switc=
h
>> 3 motherboards and 2 CPU's in 1 month), I have reached a point where I n=
eed
>> to invest a bit further. My current Gigabyte GA970 motherboard is workin=
g
>> perfectly, except that the onboard sound (Realtek) is aweful, with a who=
le
>> lot of high-pitch hiss accompanying the sound whenever I try to play any
>> music.
>
> That sounds terrible. Which sound driver do you currently use?
>
> Example:
>
> % dmesg | grep ^hda
> hdac0: <VIA VT8251/8237A High Definition Audio Controller>
> 	mem 0xbfffc000-0xbfffffff at device 1.0 on pci128
> hdac0: HDA Driver Revision: 20100226_0142
> hdac0: [ITHREAD]
> hdac0: HDA Codec #0: VIA VT1708_8
>
> % dmesg | grep ^pcm
> pcm0: <HDA VIA VT1708_8 PCM #0 Analog> at cad 0 nid 1 on hdac0
> pcm1: <HDA VIA VT1708_8 PCM #1 Analog> at cad 0 nid 1 on hdac0
> pcm2: <HDA VIA VT1708_8 PCM #2 Digital> at cad 0 nid 1 on hdac0
>
> % cat /dev/sndstat
> FreeBSD Audio Driver (newpcm: 32bit 2009061500/i386)
> Installed devices:
> pcm0: <HDA VIA VT1708_8 PCM #0 Analog> (play/rec) default
> pcm1: <HDA VIA VT1708_8 PCM #1 Analog> (rec)
> pcm2: <HDA VIA VT1708_8 PCM #2 Digital> (play)
>
> This machine is using a VIA on-board audio chipset, using the
> snd_hda driver included in the (custom) kernel.
>
>
>
>> I would like to solve the problem by installing a separate internal soun=
d
>> card - the best option appears to be Asus Xonar DG PCI Internal Sound Ca=
rd
>> with a C-Media CMI8786 chipset.
>
> In my previous home system, I had a C-Media PCI sound card
> (using the snd_cmi kernel module) which provided excellent
> playback and recording.
>
>
>
>> Will my idea of disabling the onboard
>> sound and installing the separate card work ?
>
> Yes, it should work. Disabling the on-board sound is not exactly
> required, but recommended (you _can_ have multiple audio "cards"
> in your system, but reducing the "irritation surface" is always
> a good idea).
>
>
>
>> My motherboard's BIOS does
>> provide the option to disable the onboard sound. So I think the question
>> simply boils down to whether the CMI8786 chipset be supported by the
>> FreeBSD kernel.
>
> Check "man snd_cmi" to find out if the chipset of that sound card
> is supported. Luckily, this information is easily accessible. :-)
>
>

Hi Poly,

Nice to hear from you. I knew I could always count on your reply : - )

The onboard sound would have been great had it not been for that hiss=20
that comes along. The hiss is loud enough to be a real game-spoiler. I=20
plugged in my headphones in place of the speakers, and the hiss is=20
present on the headphones too. So it had to be a problem with the=20
onboard chip or the driver. I eliminated the driver by installing=20
Windows XP, and the hiss is present in WMP playback too. So the only=20
option now is to install a separate sound card. I don't mind that, as=20
long as the card can be made to work with FreeBSD 10.x/11.

'man snd_cmi' does not list CMI8786. If FreeBSD 11 supports that=20
chipset, I can reinstall/rebuild world.

This is what I currently have :

/usr/home/bourne # dmesg | grep -iE '(hda)|(pcm)'
hdac0: <NVIDIA (0x0e0f) HDA Controller> mem 0xfe080000-0xfe083fff irq 25=20
at device 0.1 on pci1
hdac1: <ATI SB600 HDA Controller> mem 0xfe300000-0xfe303fff irq 16 at=20
device 20.2 on pci0
hdacc0: <NVIDIA (0x0051) HDA CODEC> at cad 0 on hdac0
hdaa0: <NVIDIA (0x0051) Audio Function Group> at nid 1 on hdacc0
pcm0: <NVIDIA (0x0051) (HDMI/DP 8ch)> at nid 4 on hdaa0
pcm1: <NVIDIA (0x0051) (HDMI/DP 8ch)> at nid 5 on hdaa0
hdacc1: <Realtek ALC887 HDA CODEC> at cad 0 on hdac1
hdaa1: <Realtek ALC887 Audio Function Group> at nid 1 on hdacc1
pcm2: <Realtek ALC887 (Rear Analog)> at nid 20 and 24,26 on hdaa1
pcm3: <Realtek ALC887 (Front Analog)> at nid 27 and 25 on hdaa1
pcm4: <Realtek ALC887 (Onboard Digital)> at nid 17 on hdaa1

/usr/home/bourne # cat /dev/sndstat
Installed devices:
pcm0: <NVIDIA (0x0051) (HDMI/DP 8ch)> (play)
pcm1: <NVIDIA (0x0051) (HDMI/DP 8ch)> (play)
pcm2: <Realtek ALC887 (Rear Analog)> (play/rec) default
pcm3: <Realtek ALC887 (Front Analog)> (play/rec)
pcm4: <Realtek ALC887 (Onboard Digital)> (play)





Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?VI1PR02MB09746666CAC50D3EB42D2698F6FD0>