Skip site navigation (1)Skip section navigation (2)
Date:      Sat, 17 Oct 2020 18:34:46 -0400
From:      Lowell Gilbert <freebsd-questions-local@be-well.ilk.org>
To:        Christoph Kukulies <kuku@kukulies.org>
Cc:        freebsd-questions@freebsd.org
Subject:   Re: Which ports to install to compile gnu binutils?
Message-ID:  <44y2k4cwhl.fsf@be-well.ilk.org>
In-Reply-To: <AB32D4F8-D270-4333-8F3C-219FC8E4CFB7@kukulies.org> (Christoph Kukulies's message of "Sat, 17 Oct 2020 09:21:48 +0200")
References:  <283908A2-7765-450B-9746-D51FF58C99B2@kukulies.org> <20201015214755.GB26691@geeks.org> <2F004468-03AA-4F02-9367-1A963F69ED38@kukulies.org> <448sc6szgz.fsf@be-well.ilk.org> <AB32D4F8-D270-4333-8F3C-219FC8E4CFB7@kukulies.org>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
Christoph Kukulies <kuku@kukulies.org> writes:

>> Am 16.10.2020 um 22:11 schrieb Lowell Gilbert <freebsd-questions-local@b=
e-well.ilk.org>:
>> Do you need that specific version?
>>=20
>
> Yes. Reason: I =84inherited=93 a project from someone, who passed away and
> it is to me to continue the project. He had developed everything under
> that specific
> version of the gnu-arm toolchain. I moved everything to Unix and to be
> sure that my build environment will produce the exact same results -
> which isn=92t the
> case at the moment (some instructions are assembled differently) - I=92m =
in need of the exact version.

But not necessarily permanently; only until you can verify that another
version gives you good results. [Where "good" is for you to define based
on the project's criteria.]

>> If not, the devel/binutils port with the arm-none-eabi flavor will build
>> it for you. I can't find the user documentation for using flavors at the
>> moment, but
>> # make -C /usr/ports/devel/binutils FLAVOR=3Darm_none_eabi install
>> should do it, or the equivalent for your build system (e.g.
>> # portmaster devel/binutils@arm_none_eabi
>> will also work).
>>=20
>> If you do need the specific version, then the (some would say optional)
>> first step is to badmouth the person forcing you to use a specific old
>
> :) difficult. I could stand at his grave. May God bless him.

Yeah, sounds inappropriate for this case. My sympathies to his memory.

If he were around, I'm sure you wouldn't have the problem at all.

>> version. After you've done that, you can either change the port or build
>> it by hand. Both are fairly simple: the first involves changing the
>> tarfile name in the Makefile and distinfo, while the second involves
>> unpacking the tarball and following the README instructions, which will
>> generally lead you to a 2-line command invocation.
>
> This gives me a little hope.=20

I suspect that doing everything out-of-tree until you've verified your
changes is probably the way to go. I typically do this in my own home
directory until I'm ready to package it up for production, but that's
somewhat a matter of personal style.

The tarball you quoted has a lot more than just binutils in it; the
binutils tarball is included, but lots of other things are also. The
instructions in the top directory of it seem to cover everything,
including scripts to build it. They'll all need to be adapted slightly
(for example, they assume that the base system's /bin/sh is bash, or can
be made so), but there's a full set of build scripts included for
Ubuntu, so it's a nice start.

I'd go a little further in terms of helping, but some of the details
depend on exactly what your "real" project is like and why you can't
actually use other versions.

Be well.
        Lowell



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?44y2k4cwhl.fsf>