Skip site navigation (1)Skip section navigation (2)
Date:      Sun, 9 Feb 2020 14:52:57 -0500
From:      Robert Huff <roberthuff@rcn.com>
To:        freebsd@dreamchaser.org
Cc:        FreeBSD Mailing List <freebsd-questions@freebsd.org>
Subject:   can't build port because thinks amd64 is i386?
Message-ID:  <24128.25369.350821.469545@jerusalem.litteratus.org>
In-Reply-To: <af479c2b-ea8e-7bb3-00d7-da27a312bf33@dreamchaser.org>
References:  <af479c2b-ea8e-7bb3-00d7-da27a312bf33@dreamchaser.org>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
Gary Aitken writes:
>  Trying to build darktable on an amd64 machine:
>  
>  uname -a
>  FreeBSD breakaway.dreamchaser.org 11.3-RELEASE-p6 FreeBSD 11.3-RELEASE-p6 #0: Tue Jan 28 09:37:40 UTC 2020     root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC  i386

	FreeBSD jerusalem.litteratus.org 13.0-CURRENT FreeBSD 13.0-CURRENT #0 r354131: Mon Oct 28 17:27:33 EDT 2019     huff@jerusalem.litteratus.org:/usr/obj/usr/src/amd64.amd64/sys/JERUSALEM  amd64

>  dmesg:
>  CPU: AMD Phenom(tm) II X4 970 Processor (3511.82-MHz 686-class CPU)
>     Origin="AuthenticAMD"  Id=0x100f43  Family=0x10  Model=0x4  Stepping=3
>     Features=0x178bfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,MMX,FXSR,SSE,SSE2,HTT>
>     Features2=0x802009<SSE3,MON,CX16,POPCNT>
>     AMD Features=0xee500800<SYSCALL,NX,MMX+,FFXSR,Page1GB,RDTSCP,LM,3DNow!+,3DNow!>
>     AMD Features2=0x837ff<LAHF,CMP,SVM,ExtAPIC,CR8,ABM,SSE4A,MAS,Prefetch,OSVW,IBS,SKINIT,WDT,NodeId>
>     SVM: NP,NRIP,NAsids=64
>     TSC: P-state invariant

CPU: AMD Phenom(tm) II X4 940 Processor (3015.18-MHz K8-class CPU)
  Origin="AuthenticAMD"  Id=0x100f42  Family=0x10  Model=0x4  Stepping=2
  Features=0x178bfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,MMX,FXSR,SSE,SSE2,HTT>
  Features2=0x802009<SSE3,MON,CX16,POPCNT>
  AMD Features=0xee500800<SYSCALL,NX,MMX+,FFXSR,Page1GB,RDTSCP,LM,3DNow!+,3DNow!>
  AMD Features2=0x37ff<LAHF,CMP,SVM,ExtAPIC,CR8,ABM,SSE4A,MAS,Prefetch,OSVW,IBS,SKINIT,WDT>
  SVM: NP,NRIP,NAsids=64
  TSC: P-state invariant


	I suggest this is a problem with your machine?


			Respectfully,

				Robert Huff




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?24128.25369.350821.469545>