Skip site navigation (1)Skip section navigation (2)
Date:      Sun, 24 May 2020 10:59:33 -0600
From:      Gary Aitken <>
Subject:   Re: python version issue
Message-ID:  <>
In-Reply-To: <>
References:  <> <>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On 5/24/20 10:51 AM, Thierry Thomas wrote:
> Le dim. 24 mai 20 à 18:33:12 +0200, Gary Aitken
> <> écrivait :
>> The Makefile for the standard freecad port (cad/freecad)
>> specifies: USES= ... python:3.6 ... BUILD_DEPENDS=
>> ${PYTHON_PKGNAMEPREFIX}pyside2-tools>0:devel/pyside2-tools@${PY_FLAVOR}
>> It's my understanding that a 3.6 usage should be upward compatible
>> with a 3.7 version, so I changed the USES statement to python:3.7. 
>> Unfortunately, the BUILD_DEPENDS causes problems:
> Set USES=python:3.6+

I tried that, but then it looks like it is using python 3.6 and
trying to install older versions of already-installed packages?

===>   FreeCAD-8.d821.f5.f depends on package: py36-pyside2-tools>0 - not found
===>  License BSD3CLAUSE GPLv2 accepted by the user
===>   py36-pyside2-tools-5.12.1 depends on file: /usr/local/sbin/pkg - found
===> Fetching all distfiles required by py36-pyside2-tools-5.12.1 for building
===>  Extracting for py36-pyside2-tools-5.12.1
=> SHA256 Checksum OK for pyside-setup-everywhere-src-5.12.1.tar.xz.
===>  Patching for py36-pyside2-tools-5.12.1
===>  Applying FreeBSD patches for py36-pyside2-tools-5.12.1
===>   py36-pyside2-tools-5.12.1 depends on package: py36-setuptools_scm>0 - not found
===>   py36-setuptools_scm-3.1.0 depends on package: py36-setuptools>0 - not found
===>   py36-setuptools-40.8.0 depends on file: /usr/local/bin/python3.6 - not found
===>   python36-3.6.8_1 depends on package: pkgconf>=1.3.0_1 - found
===>   python36-3.6.8_1 depends on executable: msgfmt - found
===>   python36-3.6.8_1 depends on shared library: - found (/usr/local/lib/
===>   python36-3.6.8_1 depends on shared library: - not found
===>  Installing for readline-7.0.5
===>  Checking if readline is already installed
===>   readline-7.0.5 is already installed
       You may wish to ``make deinstall'' and install this port again
       by ``make reinstall'' to upgrade it properly.
       If you really wish to overwrite the old port of readline
       without deleting it first, set the variable "FORCE_PKG_REGISTER"
       in your environment or the "make install" command line.
*** Error code 1

Despite the "readline-7.0.5 is already installed, it is not:
$ pkg info | grep readline
readline-8.0.1                 Library for editing command lines as they are typed

It seems like it needs to be using/generating py37 versions, to be
compatible with higher-numbered versions such as readline-8.0.1
instead of 7.0.5?


Want to link to this message? Use this URL: <>