Skip site navigation (1)Skip section navigation (2)
Date:      Mon, 9 Mar 2020 15:26:24 +0100
From:      Edwin Ancaer <eancaer@gmail.com>
To:        xxjack12xx@gmail.com
Cc:        freebsd-questions@freebsd.org
Subject:   Re: Problem after upgrade to 12.1: Ports Collection support for your FreeBSD version has ended,
Message-ID:  <CAMSnosM+HZ+5c_XwZYp5HshyEsPv813NHPwTPyqUHVENHkXrWQ@mail.gmail.com>
In-Reply-To: <i8bu9m5433cc8e8k4mn8t414.1583543469640@denninger.net>
References:  <i8bu9m5433cc8e8k4mn8t414.1583543469640@denninger.net>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
Hello,

thanks for helping out . One should not post mails to soon, I think I know
how I got into the 'no support' problem:

in the previous version I used poudriere to build packages from ports, and
I had disableb FreeBSD.conf and creatief a poudriere.conf file,  to use use
my self-build packages with pkg. This conf file points to 12.0, so the
message correct.

After resetting Freebsd.conf, the message disappeared, but:

$ sudo pkg install eclipse
Updating FreeBSD repository catalogue...
pkg: repository meta /var/db/pkg/FreeBSD.meta has wrong version 2
pkg: Repository FreeBSD load error: meta cannot be loaded No error: 0
Fetching meta.txz: 100%    916 B   0.9kB/s    00:01
pkg: repository meta /var/db/pkg/FreeBSD.meta has wrong version 2
repository FreeBSD has no meta file, using default settings
Fetching packagesite.txz: 100%    6 MiB 645.3kB/s    00:10
pkg: repository meta /var/db/pkg/FreeBSD.meta has wrong version 2
pkg: Repository FreeBSD load error: meta cannot be loaded No error: 0
Unable to open created repository FreeBSD
Unable to update repository FreeBSD
Error updating repositories!

I found a post where using portmaster seemed to have solved the problem,
but I don't have it installed, and pkg install gives the error...
Building it from the ports tree gives the same problem.

This is probably another side effect  of my poudriere experiments, where I
must have changed some setting without really knowing what I was doing.

I have been sleeping twice over this, but no new insights popped up.
Any ideas, about this message?


Kind regards,


Edwin Ancaer

Op za 7 mrt. 2020 om 02:11 schreef <karl@denninger.net>:

> Update -f still gives me the error
>
>
> -- Karl (on PDA)
>
>
>
>   Original Message
>
>
> From: xxjack12xx@gmail.com
> Sent: March 6, 2020 16:57
> To: eancaer@gmail.com
> Cc: freebsd-questions@freebsd.org
> Subject: Re: Problem after upgrade to 12.1: Ports Collection support for
> your FreeBSD version has ended,
>
>
> Have you tried pkg update and then pkg upgrade? Or how did you try to
> install a package?
>
> On Fri, Mar 6, 2020 at 2:47 PM Edwin Ancaer <eancaer@gmail.com> wrote:
> >
> > Hello everybody,
> >
> > I just upgraded to version 12.1, and now, when I try to install a
> package,
> > I always get the message: Ports Collection support for your FreeBSD
> version
> > has ended, and no ports are
> > guaranteed to build on this system. Please upgrade to a supported
> release.
> >
> > I suppose the upgrade went well, because the uname -a command returns
> > FreeBSD ottopedi 12.1-RELEASE-p2 FreeBSD 12.1-RELEASE-p2 GENERIC  amd64
> >
> > I freely admit I must have done something wrong, but I have no idea what.
> > Is there a way to get me out of this?
> >
> > Thanks,
> >
> > Edwin Ancaer
> > (maybe just not smart enoughto not use Windows)
> > _______________________________________________
> > freebsd-questions@freebsd.org mailing list
> > https://lists.freebsd.org/mailman/listinfo/freebsd-questions
> > To unsubscribe, send any mail to "
> freebsd-questions-unsubscribe@freebsd.org"
> _______________________________________________
> freebsd-questions@freebsd.org mailing list
> https://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to "
> freebsd-questions-unsubscribe@freebsd.org"
>



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?CAMSnosM+HZ+5c_XwZYp5HshyEsPv813NHPwTPyqUHVENHkXrWQ>