Skip site navigation (1)Skip section navigation (2)
Date:      Fri, 20 Jul 2012 17:55:21 +0530
From:      Manish Jain <bourne.identity@hotmail.com>
To:        freebsd-questions@freebsd.org
Subject:   How to get Huawei EC1561 USB modem working under FreeBSD 8.2 ?
Message-ID:  <BLU0-SMTP1086684ACF08C894823C3B0F6D80@phx.gbl>

Next in thread | Raw E-Mail | Index | Archive | Help

Hello all,

I earlier had a Huawei EC1261-based USB modem which used to connect 
smoothly to the internet under FreeBSD 8.2 using the u3g module. For 
some reasons, I have had to switch to another provider (MTS) who swapped 
the Huawei EC1261-based USB modem with a Huawei EC1561-based USB modem. 
And my FreeBSD system cannot connect to the internet anymore.

Here are the contents of my ppp.conf (I assume authkey means password) :

default:
  set log Phase Chat LCP IPCP CCP tun command
  allow users bourne
  set device /dev/cuaU0.0
  set speed 115200
  set dial "ABORT BUSY ABORT NO\\sCARRIER TIMEOUT 5 \
  \"\" AT OK-AT-OK AT&FE0V1X1&D2&C1S0=0 OK \\dATDT\\T TIMEOUT 40 CONNECT"
  set timeout 180 # 3 minute idle timer (the default)
  enable dns # request DNS info (for resolv.conf)

huawei:
  set phone "#777"
  set login
  set authname "internet@internet.mtsindia.in"
  set authkey "MTS"
  set timeout 0
  disable ipv6cp
  set ifaddr 10.0.0.1/0 10.0.0.2/0 255.255.255.0 0.0.0.0
  add default HISADDR
  set dial AT+CRM=1
  accept CHAP

The u3g module is loaded at boot-time via /etc/rc.local :

kldload u3g
sleep 3
ppp -auto huawei

I am using opendns/google servers for DNS in resolv.conf :

208.67.222.222
8.8.8.8

DNS cannot really be an issue because when I ping the IP address 
208.67.222.222, I get 100% packet loss.

Can someone please point me in the right direction so that my FreeBSD 
system starts connecting to the internet using the new modem ?


Thank you &
-- 
Regards,

Manish Jain
+91-99620-10329



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?BLU0-SMTP1086684ACF08C894823C3B0F6D80>