Skip site navigation (1)Skip section navigation (2)
Date:      Sun, 24 Nov 2013 20:29:54 -0500
From:      mfv <mrkvrg@acm.org>
To:        freebsd-questions@freebsd.org
Subject:   Re: After updating ports, flash plugins for Firefox & Opera have gone AWOL
Message-ID:  <2557715.iUCYSf1lvg@gecko3.bs.net>
In-Reply-To: <9486.1385329456@server1.tristatelogic.com>
References:  <9486.1385329456@server1.tristatelogic.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
Hello Ronald,

I ran across the same problem trying to get flash to work with firefox after 
an upgrade.

As a hack, the following finally worked for me:

cd  ~/.mozilla/plugins
rm  npwrapper.libflashplayer.so
nspluginwrapper -v -a -i

Hope it may work for you.

Cheers ...

Marek

On Sun,  24 Nov 2013 13:44:16 Ronald F. Guilmette wrote:
> Having gotten past all the difficulties that related to Perl, I have
> finally managed to update essentially all of my installed ports.  (I
> still have a small problem with the update for ffmpeg(2), but I'll
> take that up later on.)
> 
> Unfortunately, after updating all my ports I find that I now have a
> problem with the flash plugins for both Firefox and Opera... and I
> could use some help solving these two problems.
> 
> After updating all my ports I have, among many many other things, all
> of the following currently installed:
> 
>     firefox-25.0_1,1
>     opera-12.16
>     linux-f10-flashplugin-11.2r202.327_1
>     nspluginwrapper-1.4.4_2
>     opera-linuxplugins-12.16
> 
> (Note:  I use both Firefox and Opera, at different times for different
> purposes.)
> 
> After updating my ports, I dutifully followed the instructions here for
> updating the flash support in Firefox (as I have done, many times before):
> 
>    https://www.freebsd.org/doc/handbook/desktop-browsers.html
> 
> Specifically (and only) I executed this step:
> 
>    nspluginwrapper -v -a -u
> 
> This produced the following output:
> 
>   Auto-update plugins from /usr/local/lib/browser_plugins
>   Looking for plugins in /usr/local/lib/browser_plugins
>   Auto-update plugins from
> /usr/local/lib/browser_plugins/linux-f10-flashplugin Looking for plugins in
> /usr/local/lib/browser_plugins/linux-f10-flashplugin Auto-update plugins
> from /home/rfg/.mozilla/plugins
>   Looking for plugins in /home/rfg/.mozilla/plugins
> 
> Then I quit and restarted Firefox.
> 
> Unfortunately, after these steps entering "about:plugins" in the Firefox
> location bar now shows that I have -no- plugins installed.  Additionally,
> upon visiting (in Firefox) a web page that I believe contains flash
> material, I am getting a notification that I need to install the flash
> plugin.
> 
> So, my questions:
> 
> 1)  What did I do wrong?
> 
> 2)  How can I correct the situation and get flash working with Firefox
> again?
> 
> Separately and additionally, Opera also now does not seem to believe that
> it has any flash pulgin installed either.  Of course, I would like to
> correct this problem also.
> _______________________________________________
> freebsd-questions@freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe@freebsd.org"



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?2557715.iUCYSf1lvg>