Skip site navigation (1)Skip section navigation (2)
Date:      Sun, 21 Jun 2020 14:56:25 +0200
From:      Jacques Foucry <jacques+freebsd@foucry.net>
To:        freebsd-questions@freebsd.org
Subject:   Re: Xorg, lightdm, xfce & German Keyboard
Message-ID:  <20200621125625.GU16409@mithril>
In-Reply-To: <20200621143043.d1fa826f.freebsd@edvax.de>
References:  <636e8210-85df-6142-22c8-5393333494d3@chemie.uni-hamburg.de> <20200621101222.576d5977@archlinux> <92c75d0893dcbb9ba395b1e8352f02be25d45d7e.camel@riseup.net> <3e3de7a2-fe5a-ec9a-1755-dd1b3f383408@chemie.uni-hamburg.de> <20200621143043.d1fa826f.freebsd@edvax.de>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
Le dimanche 21 juin 2020 à 14:30:43 (+0200), Polytropon à écrit:
> On Sun, 21 Jun 2020 10:59:16 +0200, Christian Schmidt wrote:
> > Good "morning" Ralf, ;-))
> > 
> > On 6/21/20 10:24 AM, Ralf Mardorf wrote:
> > > I still didn't read/understand correctly.
> > > 
> > > I apologize again!
> > 
> > No, I have to apologize: I should have mentioned that I already defined
> > 
> > Section "InputClass"
> >          Identifier "system-keyboard"
> >          MatchIsKeyboard "on"
> >          Option "XkbLayout" "de"
> >          Option "XkbModel" "pc105"
> >          Option "XkbVariant" "nodeadkeys"
> > EndSection
> > 
> > in /usr/local/etc/X11/xorg.conf.d/keyboard.conf. KB layout in general 
> > works as expected - except from umlauts.
> 
> I recently had the same problem after upgrading X - the keyboard
> settings for the german language in a /usr/local/etc/X11/xorg.conf.d/
> file did no longer work (nor did the keyboard work at all); I had
> to set them in a per-user manner using setxkbmap in ~/.xsession,
> as you already correctly did, with the exception that display managers
> don't read ~/.xinitrc, they use ~/.xsession (problem already solved).


Hum… that strange for me to.

I made a symlink lsn -s .xinitrc .xsession but many commands are not executed:

xrandr --output DP2-1 --mode 2560x1440
xrandr --output DP2-1 --primary
xrandr --output eDP1 --off
setxkbmap -model logitech_base -layout us -variant altgr-intl -option terminate:ctrl_alt_bksp,misc:typo,compose:lwin
if [ -f ~/.Xmodmap ]; then
  xmodmap ~/.Xmodmap
fi

exec i3


The keybaord iѕ ok but the xrandr commandせ are not executed.

If I launch `sh .xinitrc` after login it works.

I suppose they are not in the right file, but which is the good one?


If someboday had an advice…

Thanks in advance.
-- 
Jacques Foucry



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?20200621125625.GU16409>