Skip site navigation (1)Skip section navigation (2)
Date:      Mon, 28 Oct 1996 09:20:45 -0800
From:      Amancio Hasty <hasty@rah.star-gate.com>
To:        gwh@spiders.com (Gene W Homicki)
Cc:        multimedia@freebsd.org
Subject:   Re: rah.star-gate.com:/pub/guspnp5.tar.gz 
Message-ID:  <199610281720.JAA03858@rah.star-gate.com>
In-Reply-To: Your message of "Mon, 28 Oct 1996 11:38:14 EST." <199610281638.LAA02359@charlotte.spiders.com> 

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
Hi,

Apply this patch:
*** gus_wave.c~ Sat Oct 26 11:29:31 1996
--- gus_wave.c  Mon Oct 28 09:17:35 1996
***************
*** 228,234 ****
  
  /************************************************************************/
  /* Definitions for CONFIG_2 register                                    */
! #define CODEC_CFIG2I_DEFAULT    0x80
  #define CODEC_OFVS 0x80  /* Output Full Scale Voltage */
  #define CODEC_TE   0x40  /* Timer Enable */
  #define CODEC_RSCD 0x20  /* Recors Sample Counter Disable */
--- 228,234 ----
  
  /************************************************************************/
  /* Definitions for CONFIG_2 register                                    */
! #define CODEC_CFIG2I_DEFAULT    0x81
  #define CODEC_OFVS 0x80  /* Output Full Scale Voltage */
  #define CODEC_TE   0x40  /* Timer Enable */
  #define CODEC_RSCD 0x20  /* Recors Sample Counter Disable */


Or make sure that in gus_wave.c  CODEC_CFIG2_DEFAULT is defined as:
 #define CODEC_CFIG2I_DEFAULT    0x81

>From The Desk Of Gene W Homicki :
>  +---
>  | Please download the latest guspnp driver . The mic input level problem is
>  | sort of still there just use igain to lower or raise the mic input level;h
owever,
>  | you still have to select mic as the input source.
>  +---
> 
> 	I still have the looping audio problem.  I was listing to a
> broadcast on the MBONE for about 5 minutes, when the GUS PnP Pro
> started looping a few second audio clip. Also, while the audio was
> playing, it was a _little_ choppy (small drop outs every 5-7 seconds
> or so.
> 
> Is there any way to clear the looping problem short of rebooting the
> system?
> 
> This was indeed using the latest driver from:
> 
>   rah.star-gate.com:/pub/guspnp5.tar.gz
> 
> on the latest SNAP release. Thanks!
> 
> 
> 					--Gene
> 
> -- 
> Gene W. Homicki                               gwh@spiders.com
> Objective Consulting, Inc.                    http://www.spiders.com/
> Internet Presence Design                      voice: +1 914.353.3511





Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?199610281720.JAA03858>